Intellisense slow, can't turn on VS intellisense

Hi, I wish I could use it, but I'm finding R# intellisense slow to pop up.
So in R# options I have selected VS intellisense but it doesn't turn in back
on - eg no intellisense.

Any comments anyone?

Cheers,
Sam


6 comments
Comment actions Permalink

And that is using the two latest builds (235,236).

Hi, I wish I could use it, but I'm finding R# intellisense slow to pop
up. So in R# options I have selected VS intellisense but it doesn't
turn in back on - eg no intellisense.

Any comments anyone?

Cheers, Sam



0
Comment actions Permalink

Ok, as well as selecting to use VS intellisense, I need to also turn in back
on in:

"Auto list members" box in Tools -> Options -> Text Editor -> C# -> General.



And that is using the two latest builds (235,236).

>> Hi, I wish I could use it, but I'm finding R# intellisense slow to
>> pop up. So in R# options I have selected VS intellisense but it
>> doesn't turn in back on - eg no intellisense.
>>
>> Any comments anyone?
>>
>> Cheers, Sam
>>


0
Comment actions Permalink

Hello Sam,

this actually should be done automatically when you choose VS IntelliSense in
ReSharper|Options|IntelliSense - in that case ReSharper will restore 'Auto
list members'
option to whatever value it had before choosing ReSharper IntelliSense. Doesn't
it work
for you?

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Ok, as well as selecting to use VS intellisense, I need to also turn
in back on in:

"Auto list members" box in Tools -> Options -> Text Editor -> C# ->
General.

>> And that is using the two latest builds (235,236).
>>
>>> Hi, I wish I could use it, but I'm finding R# intellisense slow to
>>> pop up. So in R# options I have selected VS intellisense but it
>>> doesn't turn in back on - eg no intellisense.
>>>
>>> Any comments anyone?
>>>
>>> Cheers, Sam
>>>


0
Comment actions Permalink

In particular I am having a similar problem, and I think it may be a design flaw in the way Resharper works:

When you choose certain methods of objects with a large number of overloads or methods, VS Intellisense seems to outperform Resharper's Intellisense by an order of magnitude. The reason, it appears, is that VS only lists the most common or last used overload, whereas Resharper lists every overload.

The one example I run into most that makes me shut off Resharper Intellisense (RSIS) is Convert.ToInt32(.... as soon as I press the open parens, I might as well go get a drink and come back... but in VS intellisense (VSIS), its instant. Other methods with fewer overloads (2 or 3 or 4) resharper is great, but large overloads its sloooooow.

Second problem with the intellisense I have found is that when using RSIS, when you type the opening parens for a method, the method signature appears, if you switch lines and come back to your started signature, and type a comma to add another parameter, RSIS does not make the signature reappear, however VSIS does. This is of great assistance when you have to research something and come back to your code.

The third and final problem I have with RSIS / VSIS is with the option itself... Whenever I open VS, it always defaults to RSIS, even if I have chosen VSIS in the past, if I close VS and reopen it, it changes back. Which is annoying, but only because of the first two issues.

Hope this helps improve the product some :)

Thanks,
Chad

VS.NET 2k3, Resharper 1.5.164.4

0
Comment actions Permalink

Thanks Dmitry,

No, I have to turn it on manually in VS options, and have to do this again
each time I re-open VS.
I've now rolled back to build 219, who's working environment always works
well for me (R# intellisense and font colors) compared to later builds.

Cheers,
Sam

Hello Sam,

this actually should be done automatically when you choose VS
IntelliSense in
ReSharper|Options|IntelliSense - in that case ReSharper will restore
'Auto
list members'
option to whatever value it had before choosing ReSharper
IntelliSense. Doesn't
it work
for you?
Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Ok, as well as selecting to use VS intellisense, I need to also turn
>> in back on in:
>>
>> "Auto list members" box in Tools -> Options -> Text Editor -> C# ->
>> General.
>>
>>> And that is using the two latest builds (235,236).
>>>
>>>> Hi, I wish I could use it, but I'm finding R# intellisense slow to
>>>> pop up. So in R# options I have selected VS intellisense but it
>>>> doesn't turn in back on - eg no intellisense.
>>>>
>>>> Any comments anyone?
>>>>
>>>> Cheers, Sam
>>>>


0
Comment actions Permalink

Hello Sam,

that's odd, ReSharper should persist the values of VS 'Auto list members'
and 'Auto list params' options
once it read them when you switched on ReSharper IntelliSense. We'll check
if it really works.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Thanks Dmitry,

No, I have to turn it on manually in VS options, and have to do this
again
each time I re-open VS.
I've now rolled back to build 219, who's working environment always
works
well for me (R# intellisense and font colors) compared to later
builds.
Cheers, Sam

>> Hello Sam,
>>
>> this actually should be done automatically when you choose VS
>> IntelliSense in
>> ReSharper|Options|IntelliSense - in that case ReSharper will restore
>> 'Auto
>> list members'
>> option to whatever value it had before choosing ReSharper
>> IntelliSense. Doesn't
>> it work
>> for you?
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Ok, as well as selecting to use VS intellisense, I need to also turn
>>> in back on in:
>>>
>>> "Auto list members" box in Tools -> Options -> Text Editor -> C# ->
>>> General.
>>>
>>>> And that is using the two latest builds (235,236).
>>>>
>>>>> Hi, I wish I could use it, but I'm finding R# intellisense slow to
>>>>> pop up. So in R# options I have selected VS intellisense but it
>>>>> doesn't turn in back on - eg no intellisense.
>>>>>
>>>>> Any comments anyone?
>>>>>
>>>>> Cheers, Sam
>>>>>


0

Please sign in to leave a comment.