Organize "using" statements functionality request

Not sure if this is the right way to request features? If not please point me in the right direction!

Would it be possible to add a feature to control the ordering of the "using" statements when they're organized - kind of like what Eclipse does for Java imports.

Currently it does them all in one block, with System first, then everything else in alphabetical order. What I'd quite like to have is:

System namespaces
3rdParty namespaces ]]>
My namespaces

To determining what is 3rdparty and what is mine it would be fine to just specify a pattern (e.g. Initech.*)

5 comments
Comment actions Permalink

Currently, all system namespaces are first, then your's namespaces, and then
alias directives.
Blank lines could be inserted between these 3 groups.

If you would like another pattern, plase could you post corresponding
request to our tracker

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"James Shute" <james.shute@lehman.com> wrote in message
news:31915279.1150193469601.JavaMail.itn@is.intellij.net...

Not sure if this is the right way to request features? If not please point
me in the right direction!

>

Would it be possible to add a feature to control the ordering of the
"using" statements when they're organized - kind of like what Eclipse does
for Java imports.

>

Currently it does them all in one block, with System first, then
everything else in alphabetical order. What I'd quite like to have is:

>

System namespaces
<blank line>
3rdParty namespaces
<blank line>
My namespaces

>

To determining what is 3rdparty and what is mine it would be fine to just
specify a pattern (e.g. Initech.*)



0
Comment actions Permalink

Hello Eugene,

While there is a 'usings' subject on the go - I have a question:
I use namespace aliases and there are 2 problems:
1. They don't pop up in the code completion lists
2. When 'auto-fixing' with a light-bulb a 'using' is placed to the deeper
level instead of using the already-existing alias

Ronnie

Currently, all system namespaces are first, then your's namespaces,
and then
alias directives.
Blank lines could be inserted between these 3 groups.
If you would like another pattern, plase could you post corresponding
request to our tracker



0
Comment actions Permalink

1) They should. I'll check

2) Visit the ReSharper->Options->Using Directives page and play with the
"Add using directive to the deepest scope check box"

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Ronnie Barker" <omea@ronniebarker.me.uk> wrote in message
news:b5214412fca58c85d446b2f30ae@news.jetbrains.com...

Hello Eugene,

>

While there is a 'usings' subject on the go - I have a question:
I use namespace aliases and there are 2 problems:
1. They don't pop up in the code completion lists
2. When 'auto-fixing' with a light-bulb a 'using' is placed to the deeper
level instead of using the already-existing alias

>

Ronnie

>
>> Currently, all system namespaces are first, then your's namespaces,
>> and then
>> alias directives.
>> Blank lines could be inserted between these 3 groups.
>> If you would like another pattern, plase could you post corresponding
>> request to our tracker
>>
>



0
Comment actions Permalink

Hello Eugene,

Unfortunately not - see screenshots attached...

1) They should. I'll check

2) Visit the ReSharper->Options->Using Directives page and play with
the "Add using directive to the deepest scope check box"



Attachment(s):
NamespaceAliasNotPoppingUp.png
NamespaceAutoCompleteStep1.PNG
NamespaceAutoCompleteStep2.PNG
0
Comment actions Permalink

As far as I see, the problem is that ReSharper inserts using directive
instead of existing alias?

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Ronnie Barker" <omea@ronniebarker.me.uk> wrote in message
news:b521441305f98c8625ed60506fa@news.jetbrains.com...

Hello Eugene,

>

Unfortunately not - see screenshots attached...

>
>> 1) They should. I'll check
>>
>> 2) Visit the ReSharper->Options->Using Directives page and play with
>> the "Add using directive to the deepest scope check box"
>>


0

Please sign in to leave a comment.