Nant / MSBuild support in resharper 2 VS2003

I eagerly downloaded Resharper 2 to check out the support for nant build files looking forward to intellisense prompts etc.

Unfortunately when I open a Nant build script in my IDE resharper does nothing at all, no intellisense, no suggestions or anything despite working well with .cs files.

What am I doing wrong?

5 comments
Comment actions Permalink

chris green wrote:

I eagerly downloaded Resharper 2 to check out the support for nant build files looking forward to intellisense prompts etc.

Unfortunately when I open a Nant build script in my IDE resharper does nothing at all, no intellisense, no suggestions or anything despite working well with .cs files.

What am I doing wrong?


Is the file extension .build? I noticed that it doesn't work if you use
something else, like .nant.

Maybe it would be better if it could figure that out by looking at the
referenced xml namespace...?

Max

0
Comment actions Permalink

Hello Chris,

Currently ReSharper detects a NAnt build script only if it has ".build" extension.
There's no easy way for detecting a build script, because not all build scripts
have a proper extension and not all build scripts reference an appropriate
namespace. If you rename your file, so that it is ".build", do you see any
changes?

Thanks,
Andrew Serebryansky

I eagerly downloaded Resharper 2 to check out the support for nant
build files looking forward to intellisense prompts etc.

Unfortunately when I open a Nant build script in my IDE resharper does
nothing at all, no intellisense, no suggestions or anything despite
working well with .cs files.

What am I doing wrong?



0
Comment actions Permalink

Thank you for your reply. My file does have the '.build' extension, when I open it Visual Studio does not apply any of the formatting that it would to a normal xml file (which I would expect as it does not recognise the .build extension) however ReSharper does nothing to it either.

0
Comment actions Permalink

In Solution Explorer right click on the build file and choose Open With... In the dialog choose "HTML/XML Editor" and click Set As Default. Then click Open and see if that fixes things.

I don't know if this will have any effect on ReSharper but it should certainly affect VS treating it as an XML file.

HTH,

Sam

0
Comment actions Permalink

Thank you, that sorted the problem out, after copying the Nant schema locally as well resharper is now offering me intellisense.

0

Please sign in to leave a comment.