Installation issues and issues in general

I am wondering if anyone else as experienced this issue with the latest version of R#, it takes an hour to install. Yes, I said an hour. I thought I was crazy, so I tried it on three separate machines, even one which had a new installation of Windows. Has anyone else had this problem? Also, there seems to be an issue with R# becoming VERY unstable and slow when a solution has many projects and including web projects. I am sorry to see what was a great add-in product become a very heavy and slow. In the end, becomes very usefulness when it reports missing methods when they are not but just missing from the R# cache and the only way to solution that is unload and re-load R# . I hope the later builds solve these issues of instability.

4 comments
Comment actions Permalink

Hello Brian,

this is a known issue that the installation is slow. However, it should nevertheless
be within reasonable time margins - approx. 7-8 minutes. Is there anything
specific in your hardware / software configuration? Thanks.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I am wondering if anyone else as experienced this issue with the
latest version of R#, it takes an hour to install. Yes, I said an
hour. I thought I was crazy, so I tried it on three separate machines,
even one which had a new installation of Windows. Has anyone else had
this problem? Also, there seems to be an issue with R# becoming VERY
unstable and slow when a solution has many projects and including web
projects. I am sorry to see what was a great add-in product become a
very heavy and slow. In the end, becomes very usefulness when it
reports missing methods when they are not but just missing from the R#
cache and the only way to solution that is unload and re-load R# . I
hope the later builds solve these issues of instability.



0
Comment actions Permalink

Hello Dmitry,

I experience the same 1 hour installation time as well.

Hello Brian,

this is a known issue that the installation is slow. However, it
should nevertheless
be within reasonable time margins - approx. 7-8 minutes. Is there
anything
specific in your hardware / software configuration? Thanks.
Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> I am wondering if anyone else as experienced this issue with the
>> latest version of R#, it takes an hour to install. Yes, I said an
>> hour. I thought I was crazy, so I tried it on three separate
>> machines, even one which had a new installation of Windows. Has
>> anyone else had this problem? Also, there seems to be an issue with
>> R# becoming VERY unstable and slow when a solution has many projects
>> and including web projects. I am sorry to see what was a great
>> add-in product become a very heavy and slow. In the end, becomes very
>> usefulness when it reports missing methods when they are not but just
>> missing from the R# cache and the only way to solution that is unload
>> and re-load R# . I hope the later builds solve these issues of
>> instability.
>>


0
Comment actions Permalink

Hello Matthew,

so the same question for you - is there anything specific in your environment?
Are you sure that you close all instances
of VS and MSDN browser before installation? Thanks.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Dmitry,

I experience the same 1 hour installation time as well.

>> Hello Brian,
>>
>> this is a known issue that the installation is slow. However, it
>> should nevertheless
>> be within reasonable time margins - approx. 7-8 minutes. Is there
>> anything
>> specific in your hardware / software configuration? Thanks.
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> I am wondering if anyone else as experienced this issue with the
>>> latest version of R#, it takes an hour to install. Yes, I said an
>>> hour. I thought I was crazy, so I tried it on three separate
>>> machines, even one which had a new installation of Windows. Has
>>> anyone else had this problem? Also, there seems to be an issue with
>>> R# becoming VERY unstable and slow when a solution has many projects
>>> and including web projects. I am sorry to see what was a great
>>> add-in product become a very heavy and slow. In the end, becomes
>>> very usefulness when it reports missing methods when they are not
>>> but just missing from the R# cache and the only way to solution that
>>> is unload and re-load R# . I hope the later builds solve these
>>> issues of instability.
>>>


0
Comment actions Permalink

I just installed build 256 and it took about 15 minutes.
There were long periods of time where the CPU was running 1-2% as if the
installer was waiting for something.
Jeff


0

Please sign in to leave a comment.