Resharper incorrectly highlights variables as unresolved

Hi,

Resharper 2.5 is incorrectly highlighting variables as 'Unresolved'. I am using the MS Enterprise Library 2006 which is where the DatabaseFactory object comes from. I have attached a screenshot.

Additionally, I also notice that web service client side proxy classes (as generated by VS05 Add Web Reference) incorrectly get highlighted in red (see attachment: resharper_webservice.jpg).

Code compiles just fine.

Any ideas?

Kevin

Message was edited by:
Kevin Kenny



Attachment(s):
resharper-error.jpg
resharper-error2.jpg
resharper-webservice.jpg
4 comments
Comment actions Permalink

Hello,

We appreciate your feedback.

The corresponding JIRA request has been created, and you are welcome to monitor
its status at http://www.jetbrains.net/jira/browse/RSRP-33546.

Best regards,
- Development Team.


0
Comment actions Permalink

Hi,

I'm experiencing the same problem with web service proxy classes.
I see that the JIRA only addresses the first issue. Is there another issue registered for the web service issue?

/Baard

0
Comment actions Permalink

Baard,
Could you create a small sample for us? We've been reported similar issues
with webservices recently but failed to reproduce.
If you're unable to publish your solution, you may send it to me directly to
qx at jetbrains dot com.
Thanks in advance.
--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

it was incurred by .disco files in web references, that were not processed correctly by R#
The upcoming nightly build #339 will contain the fix

0

Please sign in to leave a comment.