Resharpers Reformat code changes too much

Resharpers Reformat code changes all my classes visibility from public to internal.

How do I chage that annoying setting?

3 comments
Comment actions Permalink

Hello Gipda,

Can you give us code example when it happens?

Note, that default class visibility is indeed "internal", so when you write
"class A {}" you've got an internal, not public class. ReSharper just makes
this explicit by inserting the keyword. You can disable inserting of this
keyword in the ReSharper formatting options: Options / Languages / C# / Formatting
Style / Other, see modifiers section out there.

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


G> Resharpers Reformat code changes all my classes visibility from
G> public to internal.
G>
G> How do I chage that annoying setting?
G>


0
Comment actions Permalink

Sure. It changes :

++++++++++
public class Lists {
}
++++++++

to:

++++++++++
internal class Lists {
}
+++++++++

and it does it to all my .cs classes

Message was edited by:
Gipda

0
Comment actions Permalink

Hello Gipda,

That's VERY weird. I can't reproduce it, could you give us a bit more details?
Do you reformat a file, a selection, a project or a solution?
Could you please send us your UserSettings.xml file? It should be located
in your Application Data folder:
"C:\Documents and Settings\\Application Data\JetBrains\ReSharper\v3.0\vs8.0" Sincerely, Ilya Ryzhenkov JetBrains, Inc http://www.jetbrains.com "Develop with pleasure!" G> Sure. It changes : G> G> ++++++++++ G> public class Lists { G> } G> ++++++++ G> to: G> G> ++++++++++ G> internal class Lists { G> } G>]]> +++++++++


0

Please sign in to leave a comment.