ReSharper Menu Disabled On Load

Here's a weird one.

If I open Visual Studio 2005 from the Start Menu, the ReSharper menu is active and ready for use.

However, if I open a solution by double-clicking via Windows Explorer, Visual Studio will open with the solution open and ReSharper disabled.

I'm using ReSharper 2.5 (Build 376) and Visual Studio 2005 .

Message was edited by:
Shane Bauer

11 comments
Comment actions Permalink

Hello Shane,

it would be helpful if you tell us what version/build of ReSharper you're
running?


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


Here's a weird one.

If I open Visual Studio 2005 from the Start Menu, the ReSharper menu
is active and ready for use.

However, if I open a solution by double-clicking via Windows Explorer,
Visual Studio will open with the solution open and ReSharper disabled.



0
Comment actions Permalink

Hi Dmitry,

it would be helpful if you tell us what version/build of ReSharper you're 
running?


I have the same thing with the latest beta version (456?).

Cheers,

Julian

0
Comment actions Permalink

Hello Julian,

could you please try to Reset All Settings (Tools|Import and Export Settings)
and check if it helps? Thanks.


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


Hi Dmitry,

>> it would be helpful if you tell us what version/build of ReSharper
>> you're running?
>>

I have the same thing with the latest beta version (456?).

Cheers,

Julian



0
Comment actions Permalink

I would also recommend checking the "Tools -> Add-in Manager" to make sure the "Startup" box is checked.

In my system, even if I uncheck the box to unload resharper, the menu stays and everything is there, its just greyed out in the 3.0 betas (Even the about R# menu item!) -- See attached.

I don't know if that makes a difference on load from explorer vs start from icon, but its another thought...



Attachment(s):
Disabled.PNG
0
Comment actions Permalink

Hi Dmitry,

I've tried this as well. When I load up a project the menu isn't visible. Under Add-ins, the startup checkbox is checked for ReSharper.

Using ReSharper 2.5 (Build 376) with Visual Studio 2005.

Message was edited by:
Shane Bauer

0
Comment actions Permalink

Alright. The Menu is back up. However, it is still disabled when a solution is opened via Windows Explorer.

0
Comment actions Permalink

I had the exactly same problem when I upgraded from 3.0 Beta1 to 3.0 Beta2. See what I found as a solution -- http://www.intellij.net/forums/thread.jspa?threadID=267759&tstart=0

David.

0
Comment actions Permalink

Hello Chadwick,

sorry I'm a bit lost - that the menu is greyed out when ReSharper is unloaded
via Add-In Manager is a behavior by design.
Do you mean that your ReSharper menus are all greyed out even if the add-in
is enabled?

Thanks.


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


I would also recommend checking the "Tools -> Add-in Manager" to make
sure the "Startup" box is checked.

In my system, even if I uncheck the box to unload resharper, the menu
stays and everything is there, its just greyed out in the 3.0 betas
(Even the about R# menu item!) -- See attached.



0
Comment actions Permalink

No, Dmitry, it works the way it should, but it used to remove the menu altogether if the add in was disabled, now it doesn't... I was just saying that he might want to check if it was disabled and enable it.

No worries :)

Ciao

0
Comment actions Permalink

Hello Chadwick,

ReSharper installation makes the add-in load on VS startup by default. However,
we recently noticed that
in some cases VS ignores this setting for unknown reason - one particular
scenario (not 100% repeatable) is when a solution containing only
VB projects is opened from Windows Explorer. In this case all the installed
add-ins (ReSharper including) seem to be not loaded, although
the checkbox 'Startup' is checked for all of them. It really looks like a
VS bug. Perhaps you've run across smth similar.

Concerning the menu behavior when the user disables add-in - the menu only
gets disabled, it doesn't disappear. And it is also the way it worked
in previous versions of ReSharper - if my memory isn't wrong, ReSharper never
deleted its menus after having been disabled, it just made them greyed.

Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


I was just
saying that he might want to check if it was disabled and enable it.



0
Comment actions Permalink

I had a problem after installing 3.0 where the Resharper functionality was working fine in the text editor, but the Resharper menu in VS was grayed-out. I was unable to use the Resharper menu.

I checked the Add-in manager and confirmed that the add-in was loaded and set to load on startup. I then uninstalled Resharper and reinstalled it. Still no luck. I then downloaded the latest EAP version and installed that--still no luck.

Finally, I did what was suggested in this thread and went to Tools --> Import/Export Settings and reset my VS environment settings. Success!

All is now good.

Hope this is helpful to someone else...

Art

0

Please sign in to leave a comment.