Shift-Tab

I had to uninstall my Resharper 2.5.3 and Visual Studio 2005 environment,
and then reinstall everything.

So I have a freshly installed Visual Studio 2005 and Resharper 2.5.3 on my
system

The first time I selected some text and hit Shift-Tab to un-indent it,
Resharper presented me with a dialog that gave me two options, both of which
were wrong.

Help?!?


How do I get my Shift-Tab back?!? Resharper shouldn't TOUCH that key
combination! Ever! You cannot remap it with the Keyboard Options (if you
try to press Tab or Shift-Tab in the keyboard shortcut box, it just moves
the focus, rather than recording the keypress combination).

I vaguely remember there being a thread about this a while ago, but I can't
recall it now... so I can't figure out how to get my keypress back.

1 comment
Comment actions Permalink

Hello Paul,

I recommend that you're try the following steps in their order:

1) Use 'Reset' button in the Tools|Options|Environment|Keyboard dialog.
2) If this doesn't help, try 'Reset All Settings' in Tools|Import and Export
Settings.

After each step you will need to reset ReSharper keyboard mappings in ReSharper|Options|General|Apply...


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


I had to uninstall my Resharper 2.5.3 and Visual Studio 2005
environment, and then reinstall everything.

So I have a freshly installed Visual Studio 2005 and Resharper 2.5.3
on my system

The first time I selected some text and hit Shift-Tab to un-indent it,
Resharper presented me with a dialog that gave me two options, both of
which were wrong.

Help?!?

How do I get my Shift-Tab back?!? Resharper shouldn't TOUCH that key
combination! Ever! You cannot remap it with the Keyboard Options (if
you try to press Tab or Shift-Tab in the keyboard shortcut box, it
just moves the focus, rather than recording the keypress combination).

I vaguely remember there being a thread about this a while ago, but I
can't recall it now... so I can't figure out how to get my keypress
back.



0

Please sign in to leave a comment.