Cannot resolve symbol "Columns" - Telerik Grid and ReSharper

I am having "Cannot resolve symbol 'COLUMNS'" error similar to the ticket RSRP-18041 when I use telerik grid as shown below.

]]>

Does anyone know if this is a confirmed problem? I tried latest version of both telerik classic grid and Prometheus one, the problem remains same.

BTW, I am using latest version of ReSharper, which is v3.1 build 584.

Thanks

7 comments
Comment actions Permalink

What build are you using? Everything is ok in ReSharper 4.0 build 780.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

As mentioned in the first post, we are using ReSharper 3.1 Full Edition build 3.1.584.3 on Visual Studio 2005 SP1.

BTW, do we have a firm release date for version 4.0?

Thanks

0
Comment actions Permalink

Has there been a resolution to this issue yet? We are also using Resharper 3.1 Full Edition and given our current budget woes, probably will not be able to upgrade to 4.0 for the foreseeable future, but we'd still like to not get errors when we use the Telerik RadGrid "COLUMNS" in our aspx pages... Any chance you can fix this for Resharper 3.x users?

0
Comment actions Permalink

Frankly speaking, the chances are very low. The ASP support was
significantly rewritten and most likely it won't be possible to port the fix
into the 3.1 version.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

I guess I'm a little confused. Doesn't Resharper look at the reference/dll used to generate the control and determine if the tags used are valid? I guess I always assumed that's what was happening. If that's the case, then isn't it a bug if it can't figure out that the Telerik control has a "COLUMNS" tag exposed? I would assume that any bugs in the product would be fixed, regardless of whether we upgrade to the next version or not...?

0
Comment actions Permalink

I'm having similar problem with DevExpress ASPxGrid. The grid takes a ]]> tag. Resharper flags an error in my markup : 'Cannot resolve symbol DETAILROW' < note upper case.

I'm using 4.0.811.49 although the problem has been persent on all 4.0 builds I've tried.

0
Comment actions Permalink

David,

Could you send us a small sample solution?
BTW I didn't find any ASPxGrid control in DevExpress, with ASPxGridView
everything is fine.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"David Arkley" <no_reply@jetbrains.com> wrote in message
news:18486893.43811212154205279.JavaMail.jive@app4.labs.intellij.net...

I'm having similar problem with DevExpress ASPxGrid. The grid takes a
<DetailRow> tag. Resharper flags an error in my markup : 'Cannot resolve
symbol DETAILROW' < note upper case.

>

I'm using 4.0.811.49 although the problem has been persent on all 4.0
builds I've tried.



0

Please sign in to leave a comment.