Fonts and Colors

Hi,

Again my RS colors are missing. I've upgraded to VS9 + RS3.1 and all my RS fonts are missing in the Fonts and Color settings. I've tried multiple times to reinstall/repair to no avail. Out of desperation I've uninstalled my VS8, removed old VS registry settings in both LM and CM but still nothing. If there's nothing else to do can someone please export HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\9.0\FontAndColors\{A27B4E24-A735-4D1D-B8E7-9716E1E3D8E0} and post it so I can get my settings to work.

Thanks Heaps

5 comments
Comment actions Permalink

Heaps,

Here is my slice of the registry. I'm not sure if it contains everythig you are looking for.



Attachment(s):
Registry.reg
0
Comment actions Permalink

Hi Peter,

Thanks for the replay. That one looks a bit empty, maybe the color settings are now stored somewhere else. I've had a look and both my previous versions of VS had "Resharper XXX" entries in {A27B4E24-A735-4D1D-B8E7-9716E1E3D8E0} key. VS7 & 8's registry key looks more or less like the bit below that's why I assumed VS9 would be similar. Can someone else have a look as well please.

Thanks


"Colorable item format version"=dword:00000008
....
"XML Element Name Foreground"=dword:01000004
"XML Element Name Background"=dword:02000000
"XML Element Name FontFlags"=dword:00000000
"ReSharper Current Line Foreground"=dword:00e22b8a
"ReSharper Current Line Background"=dword:00e0ffff
"ReSharper Current Line FontFlags"=dword:00000000
"ReSharper Dead Code Foreground"=dword:00a9a9a9
"ReSharper Dead Code Background"=dword:00faf9f8
"ReSharper Dead Code FontFlags"=dword:00000000
"ReSharper Matched Brace Foreground"=dword:00e22b8a
"ReSharper Matched Brace Background"=dword:00ffff00
"ReSharper Matched Brace FontFlags"=dword:00000000
"ReSharper Operator Identifier Foreground"=dword:00808000
"ReSharper Operator Identifier Background"=dword:00faf9f8
"ReSharper Operator Identifier FontFlags"=dword:00000000
... and heaps more

0
Comment actions Permalink

Right, so I got some RS registry settings in the VS9 key mentioned previously. The colors are applied but the RS colors does not show up in VS's Fonts & Colors. What a pain...

0
Comment actions Permalink

Me again...

Just upgraded to ReSharper 4 but still no entries in "Fonts & Colors". I actually uninstalled version v3 before the v4 install to try and give it a clean slate. Anyone else having the same problem?

0
Comment actions Permalink

Yes. Upgrading to R#4 RTM over top of one of the RCs dropped my R# colour settings (which luckily for my team only included setting the mutable local variables to bold.)

0

Please sign in to leave a comment.