Dreadful editing performance

I just upgraded to version 4 today and the performance of the editor (in VS 2005) is dreadful. There's a delay of at least half a second between when I start typing and when I see any changes in the editor. I tried turning of all Code Analysis but that made no difference. Let me know how I can provide more useful info. (is there a built-in profiler I can enable or something?)

Thanks,

-Kirk

41 comments
Comment actions Permalink

You need dual core to run R# smoothly.
After I switched my Athlon to dual core R# begin to work properly and the lag stopped.

0
Comment actions Permalink

Hello Serge
I did as you requested. I couldn't post the tracing file here, since it is too large. I sent it to Ilya's e-mail address at netix.ru (couldn't find any other contact on your website). Hope this will help you. Let me know if I can assist further.
Urs

0
Comment actions Permalink

Hello Urs,

I received your snapshot and now looking at it. Thank you! I will send some
questions soon.

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


UE> Hello Serge
UE>
UE> I did as you requested. I couldn't post the tracing file here, since
UE> it is too large. I sent it to Ilya's e-mail address at netix.ru
UE> (couldn't find any other contact on your website). Hope this will
UE> help you. Let me know if I can assist further.
UE>
UE> Urs
UE>


0
Comment actions Permalink

It would be beneficial for the "Send Feedback" option in the Visual Studio ReSharper menu to have an option to automatically include system/solution/project information. For example, I have this same problem with the lag while typing (probably because my solution has over 20 projects in it), and I would like to forward my environment information to the ReSharper team so they can get a detailed view of what my system/solution is like. As for now, it's not worth my time putting together a description of my environment. I'd rather turn on and off the code analysis feature as needed to reduce how the lag effects my work.

Edited by: Michael AbiEzzi on Sep 30, 2008 7:41 PM

0
Comment actions Permalink

I Must agree with these statements . i am having the same problems with Resharper 3.1 and because of that am am recommending my company not to upgrade to version 4.1 . I am working on a very large project with a lot of files , some of them over 2000 lines of code and it works extremely slow.

0
Comment actions Permalink

Hello all,

I have found this exact problem long term though Resharper versions 3 and 4. We have large solutions here, 170k lines of code in the current solution. Key presses in the code would not appear for some seconds when typing. It gets to the point where it is unusable. I have uninstalled Resharper several times and ended up reinstalling it and trying to find workarounds, just because I missed the features.

Interestingly - I was trialling version 4.1 for the last month and it suffered the same problems. I yesterday bought a license anyway as I do like the features and was planning on finding away to turn it on and off for when the performance went down. When I uninstalled it and re-installed as "C# Only" (my license) as opposed to the "Full install" I did in the trial - the problem seems to have gone away, at least in the last 24 hours I have not seen it. Could a few of you try this maybe?

I love Resharper its a great tool but this awful lag when editing is the reason I have not recommended it to the company I currently work for - it would annoy too many people.

Also, I did come up with a list of things which definitely helped reduce the lag when it appeared, you could try these.

1). Turn off the Navigation bar. Tools -> Options > Text Editor > C# > Display
2). Turn off tracking changes. Options > Text Editor > General > Settings
3). Close down "Design" files, ie. forms/dialogs in design mode (** since I installed as "C# only" I have not been editing design files either, so this could also be a cause of the delay)

These work well, but other options I have been told of are:

4). Turn off automatic compilation (which may disable some key features). Not sure where the option to do this is?
5). Clear the cache's (Resharper options menu) - which will rebuild them (may help).
6). Restart Visual Studio if memory footprint becomes too large.

7). (possible - Does Resharper store data in a the users profile? If using a roaming profile this could slow things down).
8). Try deactivating the continuous scanning in the current editor. (Again, not sure where the option for this is).

Lastly, someone on this thread has kindly posted some macros for turning the addin off and on which looks like a good idea and I will be giving them a go.

But like I said, touch wood, the delay seems to have vanished on my current install for the time being. By the way the version I was trialling in the "Full Install" mode was the same version I have installed in "C# only" now, so I don't think its a problem which has been corrected between versions.

Good luck and please post replies if this helps people. I have seen this problem for a long time now but there are really no other great alternatives to Resharper out there, its way ahead of the competition.

Martin

0
Comment actions Permalink

One more tip, closing any "Find usages" windows you have open helps the typing speed as they are updated in real time. Particulary sapping if they have the preview window open in them.

Martin

0
Comment actions Permalink

Hello Martin,

Just curious: what is the average line count per file?

We have 250K lines of code in our solution, but each file contains about
100-500 lines. Resharper has no problem with these file.

However files with 2000 or more lines of code has a slight editing delay.

--Jakob

(Ignore hyperlink on Design files above - not used to this forum - I
just mean dont keep open forms / dialogs in Designer view - seems to
slow Resharper)



0
Comment actions Permalink

Line count of the files varies a lot to be honest, 300 - 3,000 lines per file. I am seeing a slight delay at the moment, its certainly not fluid when typing but its bearable. I'd hoped it was gone for good after my last post. I have just done a quick test and the delay is the same on a 500 lined file as a 3,000. I also wait a few secs when first opening a big file while it does the code analysis on the file. Typing at this point is not really possible, too slow. I'm sure clearing the cache via Resharper -> Options -> General -> Clear Caches is helping somewhat though. Bit hard to tell as its not got too bad at the moment.

0
Comment actions Permalink

I take that back, there's a definite difference between typing in the 3,000 file and the 300 at the moment. And i have code analysis turned off.

0
Comment actions Permalink

I had these problems with early builds of 4.x, but haven't had any of these
problems recently.

Just FYI.

"alon mayaffit" <alon.mayafit@gmail.com> wrote in message
news:11249588.7911224148543450.JavaMail.jive@app4.labs.intellij.net...
>I Must agree with these statements . i am having the same problems with
>Resharper 3.1 and because of that am am recommending my company not to
>upgrade to version 4.1 . I am working on a very large project with a lot of
>files , some of them over 2000 lines of code and it works extremely slow.

0

Please sign in to leave a comment.