NUnit tests not running in Unit Runner

I've got a solution with 4 test projects, all running NUnit 2.4.8. When running the test projects, Unit Runner runs some of the projects, but the remainder don't run at all.

The gray sphere icon never changes color. It doesn't even show the green revolving icon that says it's trying to run.

Also, when selecting those projects, or any of their tests in the tree, they show no output, errors or otherwise.

Note that this isn't a new problem. I just got fed up with running the NUnit-GUI test runner.

Is there any way I can figure out what's going on?

3 comments

I just wanted to post an update.

I installed build 1212 and tried again, and the issue still happens.

I also noticed another symptom. When I first opened the solution, I ran a single test using the gutter icon, and it ran just fine. When I tried to run the test's project, all the icons stayed gray and RS didn't try to run it. When I tried to run the same test using its gutter icon again after this, it didn't run.

So It seems like RS is able to run the test but is choosing not to, for whatever reason.

0

I also had this situation.

Just as described, the tests in a project were greyed and no amount of effort, including reinstalling resharper, had any affect.

WHat I did note is the comment in the Jira record that Noam Rettig created about this phenomenon. Ilya asked if Noam had a config file in his VS test project.

I examined my config file and discovered that I had an error in the text in the config file.

However I did not receive a build errror about this and the Resharper error analysis also did not catch this error.

As soon As I fixed this text error, the test runner began to work again.

SO that's the problem cause.

Why Resharper did not alert me to the error, since it was obvious that the error did interfere with its operation, I do not know.

Thanks,

Kimball

0

Please sign in to leave a comment.