Smart Device Application projects and ReSharper

When using Smart Device Application projects ReSharper (all the versions) highlights some strange errors like: "Argument type 'System.Type' is not assignable to parameter type 'System.Type" or "Type Exception is not extend 'System.Exception'. It seems to me that it's related to the fact that these kind of projects use .Net Compact Framework (the one used for mobile devices) instead of the full-featured desktop .Net Framework version and ReSharper can't handle it correctly.
And there is another one "bug" with these projects - when you add new item (class) into the project then ReSharper doesn't want to highlight the things correctly (variables, members, etc). You need to reopen whole solution to get it work properly.

3 comments
Comment actions Permalink

Hello Roman,

both problems you've mentioned are known issues, and we're going to fix them
in the 2.0 version of the product.

Thanks for your feedback!

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

When using Smart Device Application projects ReSharper (all the
versions) highlights some strange errors like: "Argument type
'System.Type' is not assignable to parameter type 'System.Type" or
"Type Exception is not extend 'System.Exception'. It seems to me that
it's related to the fact that these kind of projects use .Net Compact
Framework (the one used for mobile devices) instead of the
full-featured desktop .Net Framework version and ReSharper can't
handle it correctly.

And there is another one "bug" with these projects - when you add new
item (class) into the project then ReSharper doesn't want to highlight
the things correctly (variables, members, etc). You need to reopen
whole solution to get it work properly.



0
Comment actions Permalink

Ok. Thanks for quick response. Look forward to the 2.0 version.

0
Comment actions Permalink

Just continue developing a legacy Smart Device project (using .NET CF 1.0, Visual Studio 2003, ReSharper 2.0.4).
Nearly everything works fine but having the same issues desribed in this thread.


e.g. "Argument type 'System.Type' is not assignable to parameter type 'System.Type"

Does the problem still exists or has it been fixed?

--hfr

0

Please sign in to leave a comment.