Undo - Ctrl+Z

Has anyone else noticed Undo (e.g. pressing Ctrl+Z) is broken after
installing ReSharper 4.5.1? I've confirmed Ctrl+Z is bound to Edit.Undo and
even replaced the binding just in case... but Undo still doesn't work.

5 comments

Yes, happened to me as well, not regularly though... Sometimes all of a sudden cntr-z is not enabled, and always at the moments you really NEED it it seems... :/

I'm thinking about going back to 4.5.0, at least it worked better.

0

This is happening to me too, but for me this specific problem was what lead me to update to 4.5.1.

I haven't noticed any pattern yet, but the problem is that undo suddenly stops working for individual files. Closing and re-opening the file results in undo working for a while. It's not only that ctrl-z doesn't work, Edit - Undo is disabled.

JetBrains people, please respond.

0

Yes I have the same problem in 4.5.1. It seems to occur only after a large number of updates to one file. Like mentioned if you close the file and re-open it the undo feature is back again.

0

Same thing happens to me quite often. It is incredibly annoying.. at best.

0

Hello,

There are, supposedly, three scenarios for the issue:

(1) You got a LiveTemplate open, but not completed, in some other file.

LiveTemplates do suppress the Undo functionality for a while, until you complete
the template (either TAB thru all the firlds, or ESC out of it). However,
you have to press these keys in the same file the Live Template is. Sometimes
it's easy to wander off to some other file without closing the template.
For example, a create-smth-from-usage to another class that lives in another
file opens a Live Template session in that file, and if you switch back quickly
you might have it still sitting there. Window :: Close All generally helps
with this. Recent Files / Recent Edits (Ctrl + <, Ctrl + Shift + <) helps
with getting back to the spot after that :)

(2) A major problem during a LiveTemplate expansion.

If there's an exception while a Live Template session is running, potentially
it could break the Undo functionality by not restoring it properly.

(3) Some random bad thing.

No comments ... Sometimes it's possible to break VS even without R#, but
with R# we sometimes get random exceptions out of the OLE Undo subsystem.
Need some clues on how to repro. There're much more things that play with
OLE Undo than just LiveTemplates (refactorings etc), but it seems that only
the Live Templates really keep it suspended for a long time.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.