ReSharper 5 "Find Usages" extremely slow

I'm using ReSharper 5 (nightly builds including the beta).
When I "Find Usages"/Shift-F12 on a method a "Searching for usages" window opens and usually around 20 seconds to complete.
This happens for most searches in a session, including repeat ones.
The solution is a web app, with about 25 projects with about 1700 total files (mostly .cs, some .as?x)

I don't recall this happening in ReSharper 4.5.

Has anyone else experienced this? Is there a setting to set? Is this a bug?

Thanks!

4 comments
Comment actions Permalink

orip x wrote:

I'm using ReSharper 5 (nightly builds including the beta).
When I "Find Usages"/Shift-F12 on a method a "Searching for usages" window opens and usually around 20 seconds to complete.
This happens for most searches in a session, including repeat ones.
The solution is a web app, with about 25 projects with about 1700 total files (mostly .cs, some .as?x)

I don't recall this happening in ReSharper 4.5.

Has anyone else experienced this? Is there a setting to set? Is this a bug?


Is there any ASP.NET MVC project in solution.

0
Comment actions Permalink

Hi Slava,

Yes, we do.
Actually, we have WebForms and ASP.NET MVC in the same project.

0
Comment actions Permalink

Hi,

Is it possible to send us your solution for investigation? Also you could
try to take performance snapshot by our profiling tool
DotTrace and send it to us.
Thanks in advance!

--
Kirill Falk
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi Slava,

Yes, we do.
Actually, we have WebForms and ASP.NET MVC in the same project.
---
Original message URL:
http://www.jetbrains.net/devnet/message/5253313#5253313



0
Comment actions Permalink

Hi Kirill,

I don't have a DotTrace license, is there a way I can run it for taking the snapshot?
Sadly, I can't send the solution.

Thanks.

0

Please sign in to leave a comment.