Can't close intellisense dropdownlist using Esc key

I used to be able to close the intellisense dropdownlist using the Esc key. Now it doesn't work. I have to click anywhere on the editor to close it. I can't find the setting for this. Any ideas?
Using VS  2008 SP! & R# 4.5.2 on XP.

3 comments
ESC key stopped working? One-time reset of VS shortcuts will fix it. More info at community newsgroups or their web mirror.
0

I just started having the same problem.  I am using VS2008 and noticed the problem today when using Intellisense in the VB.NET code-behind window in an ASP.NET website.  It seems I used to be able to close out of Intellisense, parameter tooltips, etc by hitting the escape (ESC) key.  Now it no longer works.  I followed the link posted by the first responder to this post but none of those options worked.  I tried resetting the Keyboard mapping scheme and even verifying that the Esc key was mapped properly to the shortcuts mentioned in the linked article.  Tried restarting VS2008 after applying fix and nothing worked.  Anyone had this problem and found a solution?  Thanks!

0

OK - Strangely this just started working.  After trying the suggestions in the above link (and restarting VS2008) I honestly started thinking my ESC key was broken

I switched over to MS Word to see if I could get the ESC key to work there and I could not.  I then switched over to two different non-MS products (Photoshop and iTunes - both of which were open at the time) and both of those apps detected the ESC key as normal.  Right after that I switched back to VS2008 and everything started working as normal.  Black magic?  Perhaps.  But since there aren't that many articles on this problem I thought I would post my experience.  Maybe the ESC key was "stuck" somehow in the MS apps and I woke it up somehow!  If anyone else continues to have this problem or finds a different solution, please share with us!!!

0

Please sign in to leave a comment.