Cannot get Resharper to stop highlighting local variables

I'm using Resharper 4.5 in VS 2005.  My local variables seem to be highlighted in purple, which is extremely distracting when you're trying to read code.  I can't seem to find a setting that will turn this off.  I've looked at the post below and I don't have an option for "ReSharper Mutable Local Variable" in the Display Items.  I've also made sure "Color Identifiers" is set to off under Resharper --> Code Inspection --> Settings.  Any help would be really appreciated.

http://resharper.blogspot.com/2008/05/functional-style-highlight-mutable.html

Thanks!
  Lidiya

6 comments

Hello,

Do you have VS 2005 Service Pack 1 installed?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

I'm using VS 8.0.50727.42, which I think is prior to SP1.  I've also checked the registry and it doesn't look like SP1 is installed.

0

I'm getting the same problem all of a sudden (after months of working without any trouble).  Very distracting and very disappointing.  Anybody have a resolution?

later...

Installing vs2005 SP1 seems to have fixed this.

Message was edited by: brettman

0

Hello
     Which version of Visual Studio do you use? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"
0

Hi, thanks for quick reaction time! The problem was only effecting  vs2005 pro, which I don't use very often. Anyway installing SP1 seems to have fixed it.  I also reset the devenv settings.

0

Hello,

Hi, thanks for quick reaction time! The problem was only effecting
vs2005 pro, which I don't use very often. Anyway installing SP1 seems
to have fixed it.  I also reset the devenv settings.


VS2005 has critical issues in the highlighting subsystem. Installing SP1
is really a must.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.