Resharper crasches my Visual Studio with The type initializer for'DevExpress.XtraTreeList.TreeList' threw an exception

Hello,

I realized that the thread I first posted this in was quite old... maybe it gone stale. In other case - sorry for double-posting.

OK - here is the case:

I have a Visual Studio 2008 with my beloved Resharper 4.5. Everything was working fine. And then this Tuesday it just started to crash on me, with the exception above.

Since I used DevExpress's tools for an old customer I uninstalled them (I don't need them) thinking that they interfered with Resharper in someway. But lo and behold, after uninstalling DevExpress and rebooting I still get the same error!

OK - I then found this thread: http://www.jetbrains.net/devnet/message/5234222 but as I said, I was scared that it was old, and no-one checked it.

As I understand the solution to that problem was a .licx-file. But I have searched my system and deleted them. No luck - Reharper crashes on all commands i've tried.

Any tip on how to solve this - getting quite frustrating...

Thank you

/Marcus Hammarberg
www.marcusoft.net

Please sign in to leave a comment.