ReSharper 5.0 Error Highlighting in VS 2010

It seems that ReSharper is still having problems with highlighting errors in VS 2010 RC. I know people have suggested to turn on "Underline errors in the editor" and "Show live semantic errors" under C# in the VS 2010 text editor options, but ReSharper resets these settings every time I install a new build. Are there any plans to fix this issue?

9 comments
Comment actions Permalink

Hello Jameel
     Could you please clarify which problems with highlighting do you mean? Could you please attach a screenshot? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

As you can see from the screenshots, errors and warning appear in the side bar, but they aren't always highlighted (or underlined) in the editor. I've checked my VS color settings and everything seems to be fine. I've been having this issue with ReSharper 5.0 for several different builds now, including the new RC builds.



Attachment(s):
ReSharperErrorHighlighting2.jpg
ReSharperErrorHighlighting.jpg
0
Comment actions Permalink

I have got the same issue, I tried switching on the two suggested text editor options, but that didn't fix it. I don't get any highlighting at all, the underlines are missing and also these half transparent effect if there is some redundant code.

Furthermore I get frequently Resharper exceptions: "Specified argument was out of the range of valid values. Paramter name: name". Get the first ones on opening a project. After I noticed them especially when navigatting with the "go to implementations" feature (triggered by short cut, or double clicking in Find results). Don't know if there is a relation between these issues.

0
Comment actions Permalink

Same here.  In VS2008 redundant items such as 'this' appear in faint grey.  In VS2010 they remain normal color so there is no visual way to see Resharper suggestions other than by working through the code using Alt PgDown

0
Comment actions Permalink

Hello,

Please make sure you're using a compatible ReSharper-VS combination (see
notes for VS beta/RC on nightly builds page), and close all text editors
before closing Visual Studio (or just after opening the solution). In non-ASPX
files this should work stabily enough. Furthermore, there were improvements
in the recent builds.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Hello,

Furthermore I get frequently Resharper exceptions: "Specified argument
was out of the range of valid values. Paramter name: name".


This exception often results from installing an incompatble combination of
R#-VS versions, see beta/RC comments on the nightly builds download page.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

It seems to be wroking with the latest nightly build.

0
Comment actions Permalink

The latest nightly build (15.01.10) does the job, thanks!

0
Comment actions Permalink

It seems that starting with build 1615 the issue has finally been fixed! Thank you!!

0

Please sign in to leave a comment.