Changing Default behavior for Go to Declaration in 5.0

My problem is two parts,



I just started using ReSharper 5.0 today and I was looking at a call from an external source .dll, I clicked go to declaration. A little dialog popped up asking what I wanted to make as the default behavior, Object explorer, something and something else. I ended up picking object explorer. I'd also like to change this default behavior, but I can't find it anywhere in the options dialog.



Next I'm trying to use this feature "http://www.jetbrains.com/resharper/beta/beta.html#External_Sources" but since I choose the default of using the object explorer, it keeps going to that.

Is this feature implemented yet? How do you access it?

4 comments
Comment actions Permalink

As an update, I found a something Options -> Tools -> External Sources

Which seems to be the option concerning this new feature.

At first it didn't seem to update my options, but then I closed & restarted VS studio then it started working as it should.

Since there's still no help for 5.0 I'm not really sure what all these options are about.

Lastly, all I can get it to do is show me the comments, and the declaration, I was wondering if I did the settings wrong or if this is all we'll be able to see. Does anyone know?

0
Comment actions Permalink

Metadata View gives you xmldocs and declarations.
Reflector PowerToy gives you decompiled sources from Reflector.
And you can navigate to original sources if you have debugging information (symbol files, pdb).
Thats "Sources from symbol files" provider.

Those options (Object Browser, Metadata View, Sources from symbol files (in the latest build)) are also accessible from "Navigate To..." context menu.

To explore .NET framework sources place "Sources from symbol files" at the first place, ReSharper will download required symbols and sources automatically upon navigation to them.

0
Comment actions Permalink

I have the same problem. When I pressed F12 key first time after Resharper installation, the same dialog appeared. I selected Object Browser by mistake and now i can't find any option to change this behavior. I want to se metadata view after F12 or Go to definition and NOT Object Browser. Is there a way how to do that, please? Thanks a lot!
I do not see Tools->Options->External Tools  choice.

0
Comment actions Permalink

Try "ReSharper -> Options -> Tools -> External Sources" instead...

0

Please sign in to leave a comment.