can not bear the poor performance of resharper 5.0 in my vs2010

it makes coding painful. my computer is 2.5G, and dual core cpu. still suffer this painess. the typing, scrolling, and quick-fix feature is really driving me crazy!
when i suspend it, everything is fine now.
i wonder if there 's any plan to fix this problem, if so, when?

8 comments
Comment actions Permalink

Have you tried suggestions from:

http://blogs.jetbrains.com/dotnet/2010/05/resharper-50-known-issues-workarounds-and-bugfix-schedule/

or in particular:

Before you contact us with such issues suspecting ReSharper, please make sure to try the solutions provided above.
By the way, if you’re using Visual Studio 2010, have you installed Windows Automation API? Rumors say it really boosts Visual Studio performance, particularly with ReSharper.

0
Comment actions Permalink

hi,Sergei Sakharov
i already read the issues list and it didn't mention any performance improvement in 5.1 pre release version.
and my os is win 7 which is shipped with windows automation api already.
i turn off the jet annotations feature, and it turns out to be a little perf improvement.
but anyway, if i enable r#, my typing is slow, my scrolling is slow, which didn't happend in R# 4.5 with vs2008.

0
Comment actions Permalink

i also have performance problems. But i'm using Visual Studio 2008 in a virtual machine (Windows Virtual PC on Windows 7 64Bit). In the VM i'm using Windows XP SP3.

The laptop i'm using for it has 4 GB RAM and a 2,8GHz Core2Duo and i've attached 2 GB to the VM.

I'm working on a VB solution with large code files (> 5.000 lines). Process Explorer shows nearly permanent 100% cpu usage for devenv.exe and editing is very sluggy. I had similar issues during 4.5 EAP which where solved until release.

When i'm working directly on my laptop i don't see any performance problems (but here i'm working only on small solutions). As my VM resides on a USB disk maybe some of the performance will be caused by the slow transfer rate, but when i disable R# the CPU usagewent down to a normal level and editing is much less sluggy.

Regards
Klaus

0
Comment actions Permalink

Hi

That was just a suggestion ). As for me - I cant say that my VS2010 is unusable, but I have solution wide analysis disabled/broken ( http://www.jetbrains.net/devnet/message/5263825 ) which might diminish potential performance loss. BTW delay in ctrl-click is annoying ( http://youtrack.jetbrains.net/issue/NP-25  ).

Regards,
Sergei

0
Comment actions Permalink

Hello,

Was it the same project and same scenarios in VS2008? Is it an ASPX project?

There shouldn't be much more slowness in VS2010 as compared to VS2008 (other
than in a particular scenario, which we'd be glad to identify and fix). As
for ASPX, there were significant changes in R#5, and there were also numerous
improvements in this area specifically done in R#5.1 (see nightliy builds).


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

hi, Serge Baltic,
the project is different but the same type. i 'm a developer in silverlight, aspx does not matter, i dont write many aspx code.
and in vs2008, i use R# 4.5, upgrade to 5.0 in vs2010.
my collegues they all suffer from this performance issue, and they all suspend it finally.
and i already disable some features like solution wide analysis, jet annotations. and it helps just a little.
i love R#, it's greate, hope you guys can do something to make it better, not worse.

0
Comment actions Permalink

For the record, I also found the performance issues in R# 5 with VS2010, and noted conflicting advice on the cause and solution.

Possible cause: Another poster (I'm afraid I can't remember where I saw it) said they found it to be regular/constant Garbage Collection by R#/VS2010 causing the sluggishness, once R# hits a cache size maximum. It's exacerbated by SWA, as this easily fills up the cache (NB. possibly not related to your available physical memory).

Workaround:  Turning off SWA (Solution-Wide Analysis) AND RESTARTING VS removed the sluggishness for me. Just turning off SWA 'as a test' doesn't make any difference as perhaps the cache is still full?

Hope that helps, at least until we have a fix.

Kind regards,
Mark.

0
Comment actions Permalink

after attaching 2,5 GB to my VM the performance increased to an acceptable level.

0

Please sign in to leave a comment.