Unit tests will not run in Resharper 5.1

When I attempt to run unit tests from the Unit Test Sessions view or by clicking Run on the yellow/green icon in the gutter, the tests don't run; it just displays pending for a few seconds and then the test goes gray.

As near as I can tell, this symptom began after upgrade from RS 5.0 to 5.1

I've tried a few things - rebuilding, deleting the Resharper cache (_Resharper.<folder>) -- nothing fixes this.

I really miss using the Resharper features!

Any suggestions?

Environment:

VS2010

RS 5.1 (build 5.1.1753.4)

NUnit 2.5.7

Resharper | Options | Unit testing:

11-4-2010 11-20-18 AM.png

4 comments
Comment actions Permalink

Hello Art,

Does this happen with any test (even in a newly created ClassLibrary project)
or only with particular tests? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

When I attempt to run unit tests from the Unit Test Sessions view or
by clicking Run on the yellow/green icon in the gutter, the tests
don't run; it just displays pending for a few seconds and then the
test goes gray.

As near as I can tell, this symptom began after upgrade from RS 5.0 to
5.1

I've tried a few things - rebuilding, deleting the Resharper cache
(_Resharper.<folder>) -- nothing fixes this.

I really miss using the Resharper features!

Any suggestions?

Environment:
VS2010
RS 5.1 (build 5.1.1753.4)
NUnit 2.5.7
Resharper | Options | Unit testing:
Image:11-4-2010 11-20-18 AM.png

---
Original message URL:
http://devnet.jetbrains.net/message/5276834#5276834



0
Comment actions Permalink

Hi Andrey,

This happens in any test.  As a test, I also just added a brand new Test Project using the Visual Studio template, containing a single barebones unit test.

The behavior is the same as I reported:  displays pending for a few seconds and then the test goes gray.

[Update]

I have done some more testing with some interesting results:

1) I have a VS2008 project, the unit tests will run from the Resharper menu in the left hand side gutter, no problem

2) I created a brand new VS2010 solution, with a single Test Project, single unit test.  It will also run unit tests will run from the Resharper menu in the left hand side gutter, no problem.

So - apparently there is something about this particular VS2010 solution.

One thing that is different about this solution is that the web service and libraries are built on .NET 3.5, but the unit test projects are .NET 4.0 (required by VS2010).  Could the co-mingling of .NET framework verrsions be an issue?

Please let me know if there is any other information I can provide for diagnosing this issue.

Regards,

Art Gorr

0
Comment actions Permalink

Andrey, I have some more information:

I did a comparison of the test settings for the solution that works and the solution that does not work.

I was able to make the unit tests run from the left hand gutter by changing the "Data and Diagnostics" setting for code coverage, specifically to disable code coverage.

While this helps, I would prefer to have the Code Coverage option enabled.  Any suggestions?

11-8-2010 9-13-09 AM.png

0
Comment actions Permalink

Hello Art,

This is a known problem, ReSharper cannot run tests with code coverage enabled.
You can monitor the status of the following request: http://youtrack.jetbrains.net/issue/RSRP-189194
to get notified when this problem is fixed. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Andrey, I have some more information:

I did a comparison of the test settings for the solution that works
and the solution that does not work.

I was able to make the unit tests run from the left hand gutter by
changing the "Data and Diagnostics" setting for code coverage,
specifically to disable code coverage.

While this helps, I would prefer to have the Code Coverage option
enabled.  Any suggestions?

Image:11-8-2010 9-13-09 AM.png

---
Original message URL:
http://devnet.jetbrains.net/message/5277084#5277084



0

Please sign in to leave a comment.