Cannot click link in unit test stack trace

Hello,

I have a rather annoying issue. I use the built-in unit tests support to run my NUnit tests. I used to be able to click the links of the stack traces displayed in the Unit Test Session window but for some reason that does not work on this machine. The links are there, they look like links and behave like links except they don't navigate to the code it is pointing to...

The workstation is running Windows Server 2008, Visual Studio 2008 Professional sp1 and ReSharper 4.1 Full Edition build 4.1.933.3.

Thank you,
Hakon

10 comments

Hello,

Do you have security settings for IE set to High level?

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


IR> Hello,
IR>
IR> I have a rather annoying issue. I use the built-in unit tests
IR> support to run my NUnit tests. I used to be able to click the links
IR> of the stack traces displayed in the Unit Test Session window but
IR> for some reason that does not work on this machine. The links are
IR> there, they look like links and behave
IR> like links except they don't navigate to the code it is pointing
IR> to...
IR> The workstation is running Windows Server 2008, Visual Studio 2008
IR> Professional sp1 and ReSharper 4.1 Full Edition build 4.1.933.3.
IR>
IR> Thank you,
IR> Hakon
IR> ---
IR> Original message URL:
IR> http://www.jetbrains.net/devnet/message/5231289#5231289


0

> Do you have security settings for IE set to High level?

I cannot tell for sure. Group policies at this location have removed the security tab from IE7. I haven't had the same problems running Vista 32-bit with the group policy but there might be other differences. Do you have anything I can test out to see if it is the security settings in IE7 that are causing the problems?

Btw, I am not running Internet Explorer Enhanced Security Configuration (IE ESC).

Regards,
Hakon

0

>> Do you have security settings for IE set to High level?

Did you find a way for me to check this setting?

Thanks,
Hakon

0

Hello,

I really don't know off my head how to check this without IE options. But
most likely this is the case, maybe you can ask your network admins?

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


>>> Do you have security settings for IE set to High level?
>>>
IR> Did you find a way for me to check this setting?
IR>
IR> Thanks,
IR> Hakon
IR> ---
IR> Original message URL:
IR> http://www.jetbrains.net/devnet/message/5232632#5232632


0

Hey, I'm also having this problem.  My company is still stuck on IE6, but I can tweak my security configuration.  Which specific option (and in which zone) needs to be set for the links to work?

0

NUnit Stacktrace links dont work with Resharper 5 and VS 2008. Details of the environment:

JetBrains ReSharper 5.1 Full Edition
Build 5.1.1727.12 on 2010-07-07T20:40:20

Licensed to: .......
Plugins: 8
#1. “ReSharper PowerToys: csUnit” v3.0.0.0 by “JetBrains s.r.o.”
#2. “ReSharper PowerToys: Explore Type Interface” v3.0.0.0 by “JetBrains s.r.o.”
#3. “ReSharper PowerToys: FindText” v3.0.0.0 by “JetBrains s.r.o.”
#4. “ReSharper PowerToys: Current File Path Macro” v3.0.0.0 by “JetBrains s.r.o.”
#5. “ReSharper PowerToys: Make Method generic refactoring” v3.0.0.0 by “JetBrains s.r.o.”
#6. “ReSharper PowerToys: Sample Menu Items” v3.0.0.0 by “JetBrains s.r.o.”
#7. “ReSharper PowerToys: ReflectorNavigation” v5.0.0.0 by “JetBrains s.r.o.”
#8. “ReSharper PowerToys: ZenCoding” v1.0.0.0 by “JetBrains s.r.o.”
Visual Studio 9.0.30729.1.

Copyright © 2003–2011 JetBrains s.r.o.. All rights reserved.



Please fix this!

Raghu
0

Hello Raghunandan,

Could you please attach a screenshots of Start | Control Panel | Internet
Properties -> Security and Privacy tabs? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

NUnit Stacktrace links dont work with Resharper 5 and VS 2008. Details
of the environment:

JetBrains ReSharper 5.1 Full Edition
Build 5.1.1727.12 on 2010-07-07T20:40:20
Licensed to: .......
Plugins: 8
#1. "ReSharper PowerToys: csUnit" v3.0.0.0 by "JetBrains s.r.o."
#2. "ReSharper PowerToys: Explore Type Interface" v3.0.0.0 by
"JetBrains s.r.o."
#3. "ReSharper PowerToys: FindText" v3.0.0.0 by "JetBrains s.r.o."
#4. "ReSharper PowerToys: Current File Path Macro" v3.0.0.0 by
"JetBrains s.r.o."
#5. "ReSharper PowerToys: Make Method generic refactoring" v3.0.0.0 by
"JetBrains s.r.o."
#6. "ReSharper PowerToys: Sample Menu Items" v3.0.0.0 by "JetBrains
s.r.o."
#7. "ReSharper PowerToys: ReflectorNavigation" v5.0.0.0 by "JetBrains
s.r.o."
#8. "ReSharper PowerToys: ZenCoding" v1.0.0.0 by "JetBrains s.r.o."
Visual Studio 9.0.30729.1.
Copyright © 2003-2011 JetBrains s.r.o.. All rights reserved.

Please fix this!

Raghu

---
Original message URL:
http://devnet.jetbrains.net/message/5283336#5283336



0

Hi Andrey,


Sorry for delayed response. I have attached the security and privacy tab screen shots.

just to reiterate
the environment is:
64bit win 2008 on mac book pro
vs 2008
resharper 5

Regards,
Raghu


Attachment(s):
privacy.jpg
security.jpg
0

Hi guys. I get this too, at work, using r# 5.1.3, and it affects unit test stack traces and the stack trace explorer.

It's group policies, and I managed to find out which one caused it - I disconnected from network, deleted all IE settings, started everything back up again and everything worked. Registry diffs + trial and error pointed me to:

[HKCU\Software\Policies\Microsoft\Windows\CurrentVersion\InternetSettings\Zones\3]
"2101"

This maps to the "web sites in less priveleged web content zone can navigate into this zone". Our group policy has this set to prohibited. If I remove this setting, everything works lovely. If it's there, links don't work.

Hope this helps in getting this fixed, because I miss my clickable stack traces...

Cheers
Matt

0

Matt, you are my hero for the day.  Thank you!

For me, it was actually [HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3] that did it—as Matt mentioned, it can be changed via the Internet Options control panel widget, on the Security tab, with the Internet zone, under the ‘Custom level...’ button, as the ‘Websites in less privileged web content zone can navigate into this zone’ option.

0

Please sign in to leave a comment.