Resharper License Server and Proxy

I have an offshore resource that I've had firewall ports and the proxy changed to access our Resharper License Server.  However when he tries to access it, it's telling him.  'error occured while connecting to the license server. The remote server returned an error: (407) Proxy Authentication Required.'  If he uses his browser and goes to  http://licenseServerAddress/licenseServer, he can see the dialogs to log into the license server, so I would think he'd be able to access the server through VS.

I saw something in the tracker where this may have been resolved, but what do I do in the meantime?

5 comments

Hello Greg,

ReSharper should be able to use the proxy settings defined in Internet Options.
Could you please contact me through andrew dot serebryansky at jetbrains
dot com with a screenshot of the user's proxy settings? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I have an offshore resource that I've had firewall ports and the proxy
changed to access our Resharper License Server.  However when he tries
to access it, it's telling him.  'error occured while connecting to
the license server. The remote server returned an error: (407) Proxy
Authentication Required.'  If he uses his browser and goes to
http://licenseServerAddress/licenseServer, he can see the dialogs to
log into the license server, so I would think he'd be able to access
the server through VS.

I saw something in the tracker where this may have been resolved, but
what do I do in the meantime?

---
Original message URL:
http://devnet.jetbrains.net/message/5300133#5300133



0

Hello,

I have a similar issue but in my case R# is running on VM.

Internet settings on VM contain address and port of our proxy server. Unfortunately bypassing proxy is not an option in my case.

When I open Chrome then popup is shown and I can provide username/password to access Internet. But with R# it does not work because R# can't display authentication dialog.

 

Best regards,

Volodymyr Usarskyy

0

Hello Volodymyr,

Have you tried to specify proxy settings manually in ReSharper | Options | Environment | Web Proxy Settings | Untick "Use system proxy server settings .." checkbox | Fill all fields?  

Thanks! 

0

Hi Alexander,

I am sorry, I think I haven't described my problem clear enough.

Proxy server uses my domain user credentials to authenticate. VM is not part of the domain, so I have to provide username/password manually.

So, for example, whenever I open Chrome and it tries to access network through proxy, I receive HTTP 407 error from proxy and Chrome displays an "Authentication Dialog" as fallback solution.

Unfortunately R# does not know how to display an "Authentication Dialog", that is why HTTP 407 error is the last step I can reach in Visual Studio. If I would have a way to authenticate myself, everything would be fine.

 

Thank you for your help!

0

Setting the proxy settings manually through ReSharper options worked for me. ReSharper was not able to use my proxy settings received through a PAC configuration script (and also not able to copy the values).

0

Please sign in to leave a comment.