Advice on improving Resharper 5.0 performance with VS2010

I am using the Release version of VS 2010 with the latest R# 5.0 build (release build and not nightly).
I run all this on a MacBook Pro with 4GN of RAM running Windows 7 using BootCamp.

I tried VS without R# and it performs very well but as soon as I install R#, editing the files becomes painfully slow.Scrolling up and down the .cs files is very laggy for example but the slowness is noticeable on a lot of other actions.
I already turned off the solution-wide code analysis but it's still slow. Are there other things we can "tweak" in the settings or things we can turn off to improve the performance without removing too much of the R# functionality?

Any tips would be greatly appreciated because I don't want to have to uninstall R# and lose the money I spent on the license

Ben

100 comments

Hello Benoit,

We have already investigated several performance/stability cases after ReSharper
5 release, and most of the time they were other extensions or Visual Studio
itself. I mean, before switching off things, it would be better to know the
real reason of the slowness. Is it possible you can download dotTrace 4 performance
profiler, capture a minute of slowness in a snapshot and upload it for us
for investigation? Thanks in advance.

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


BM> I am using the Release version of VS 2010 with the latest R# 5.0
BM> build (release build and not nightly).
BM>
BM> I run all this on a MacBook Pro with 4GN of RAM running Windows 7
BM> using BootCamp.
BM>
BM> I tried VS without R# and it performs very well but as soon as I
BM> install R#, editing the files becomes painfully slow.Scrolling up
BM> and down the .cs files is very laggy for example but the slowness is
BM> noticeable on a lot of other actions.
BM>
BM> I already turned off the solution-wide code analysis but it's still
BM> slow. Are there other things we can "tweak" in the settings or
BM> things we can turn off to improve the performance without removing
BM> too much of the R# functionality?
BM>
BM> Any tips would be greatly appreciated because I don't want to have
BM> to uninstall R# and lose the money I spent on the license
BM>
BM> Ben
BM>
BM> ---
BM> Original message URL:
BM> http://www.jetbrains.net/devnet/message/5261231#5261231


0

I did the capture and saved the snapshot following the instructions I found in the site.
Where should I upload the snapshot?

0

Please upload to ftp.intellij.net/.uploads and tell me name of the file.
Thanks!

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


IR> I did the capture and saved the snapshot following the instructions
IR> I found in the site. Where should I upload the snapshot?
IR>
IR> ---
IR> Original message URL:
IR> http://www.jetbrains.net/devnet/message/5261323#5261323


0

Done, the file name is resharper50-vs2010.dtp

Thank you

0

I am having exactly the same issue. Suspending resharper (disabling so it's not running) completely alleviates the symptoms. Scrolling the screen is laggy and typing is laggy at times. I touch type and it is disconcerting enough that I can't focus on what I am typing when it happens.

I have disabled the code analysis aspect and that seems to help. I am quite addicted to the navigation shortcuts so I don't want to disable resharper entirely, not to mention the fact that I have purchased a 5.0 license.

I would be happy to provide a profile if a link to instructions can be posted. Thank you for any help you can give.

0

I seem to be having the same problem... noticeably slower than VS2008 + R# 4.5.  Doesn't seem like this was the case with the RC's and Betas

0

I have uploaded two snap shots with settings to the public ftp upload listed in an above post. I hope this helps and the issue can be resolved or a workaround can be provided because I miss my inline code analysis.

JRoberts_scrolling_2010-04-23.dtp
JRoberts_typing_2010-04-23.dtp

Both of these snapshots were taken with R# code analysis on and 2010 reset with default settings.

Also, has any progress been made on the this issue?

0

Have you tried turning off the Navigation bar in Visual Studio?  I don't
know if that helps in 5.x on 2010 but it helped speed things up when 4.x
first came out on 2008...


"jrob" <no_reply@jetbrains.com> wrote in message
news:5441109.107191271986008419.JavaMail.clearspace@app8.labs.intellij.net...

I am having exactly the same issue. Suspending resharper (disabling so
it's not running) completely alleviates the symptoms. Scrolling the screen
is laggy and typing is laggy at times. I touch type and it is
disconcerting enough that I can't focus on what I am typing when it
happens.

>

I have disabled the code analysis aspect and that seems to help. I am
quite additced to the navigation shortcuts so I don't want to disable
resharper entirely, not to mention the fact that I have purchased a 5.0
license.

>

I would be happy to provide a profile if a link to instructions can be
posted. Thank you for any help you can give.

>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5261566#5261566


0

I just tried now and it doesn't seem to make any difference. Thanks a lot of the suggestion though

0

Hello
     I've checked both snapshots, and actually there's almost no ReSharper activity. Most of the time is taken by Visual Studio (and the text editor in particular). Do I understand correctly that suspending ReSharper results in huge performance improvement?

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"
0

Correct. Suspending resharper completely or suspending only code analysis restores performance to normal.

0

I can also confirm that suspending Resharper restores the normal performance of VS.
I do not see much difference if I just disable code analysis on a per file basis though.

P.S. I'd be glad to provide more profiling trace for specific scenarios if that helps

0

I am having what appears to be the same issue.  How can you suspend Resharper with uninstalling?

0

Hello Jeremy
     Could you please check if disabling only 'Color identifiers' option (under ReSharper > Options > Code Inspection > Settings) instead of fully disabling code analysis also speeds up editor interaction? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0

Hello Rob
     You can suspend ReSharper under Tools > Options > ReSharper > General. Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0

Hello Benoit
     I've asked one of the developers to take a look at the snapshot you've uploaded. I'll let you know if we require more info.

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0

I do not believe that I have had that option turned on at all.


The behaviour is exibited with the following setup for code analysis options. X denotes a check mark.



x Enable Code analysis
  _ Color Identifiers
  _ Analyze Errors in whole solution
  x Show Analysis options in bulb menu
  x Show the "Import Namespaces" action using popup


Assume value can be null
  x When entity is explicitly marked with CanBeNull attribute
  _ when entity doesn't have explicit NotNull attribute

0

I'm having exactly the same problem. Scrolling stutters and typing is often delayed. However, if I suspend Resharper performance is fine. Let me know if I can be of any help in troubleshooting.

- @stucampbell

0

Hello Stuart
     Please capture a couple of performance snapshots (following instructions at http://confluence.jetbrains.net/display/ReSharper/ReSharper+Performance+Profiling+Instructions) and upload them to ftp://ftp.intellij.net/.uploads. Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"
0

I can also confirm the same behavior on my machine (I have 3 GB though). Also running with Solution Analysis off. With Resharper active, scrolling is laggy, and typing at times. Suspending it makes everything fine. While I haven't worked enough with VS2010 to be really sure of how much its memory requirements are compared to VS2008, I have noticed that the same solution now seems to require a much larger amount - when I start it up, it's comparable, but eventually it grows much larger (which it didn't really do in VS2008, at least never so noticeable). I'm wondering if maybe there's a memory leak somewhere? I'll try and investigate more with Resharper unloaded.

0

Yeah - there's definitely a problem here.  With R# running, over time, the perform degrades to the point where literally the mouse wheel won't scroll and typing lags a second per keystroke.  Suspending R# and the IDE immediately quick (quicker than VS2008 to me).  But even right after a refresh instance of VS2010, R# running is noticeable.  Naked VS2010 is faster than naked VS2008.  VS2008+R# is significantly faster than VS2010+R#.  VS2010+R# is barely usable (especially over time).

0

We are having the same problem as well, Visual Studio 2010 and ReSharper 5.0 in C#/ASP.NET MVC 2.

For example, while editing one file that is a 1000 line .aspx file that has a 500 line block of javascript in it, there's considerable typing and scrolling delays.

We've tested on a Xeon Quad-Core E5405 2.0GHz with 4 GB RAM, and most recently on Xeon Quad-Core X5470 3.33Ghz with 8 GB RAM. The 2.0GHz CPU machine was slow to the point of easily getting 30-200 characters behind while typing, experiencing several second delays, and the 3.33 GHz machine gets just a few characters behind and sub-second delays. Disabling ReSharper leads to an immediate speed boost.

Under the profiler it goes slow enough to see what's happening more clearly, it seems like Visual Studio 2010 is refreshing the whole screen for each character typed.

We have uploaded the following traces to the ftp site ftp.intellij.net in the .uploads folder:

ReSharper5-VisualStudio2010-SlowScrollingOnAspxPage.zip
ReSharper5-VisualStudio2010-SlowTypingOnAspxPageInJavaScriptBlock.zip

We also made a profile snapshot of typing with ReSharper on and ReSharper off.
ReSharper5-VisualStudio2010-SlowTypingOnAspxPageInJavaScriptBlock-ReSharperOff.zip
ReSharper5-VisualStudio2010-SlowTypingOnAspxPageInJavaScriptBlock-ReSharperOn.zip

Perhaps it's something with the AspRawLexer or the HtmlRawLexerGenerated?

Hope this helps you guys track down the issue, it is making it really difficult for us to work with ReSharper 5.0 turned on under Visual Studio 2010 for our project.

Thanks,
Michael Ferrante

0

I am also seeing massive performance slowdowns using Resharper 5 and VS2010. I have 4GB RAM and an SSD - VS is really fast with ReSharper turned off. I tried the various beta builds of both VS and Resharper, and it was better then!

Thanks

James

0

I just registered to say that I have exactly the same problem. I had been using the ReSharper 5.0 trial for 3 days, and just now it has become unusable. I can't open files anymore, t is now impossible to work in Visual Studio 2010 with ReSharper enabled!

I hope there's an easy fix, otherwise this has been a short trial...

Edit:

Here's a screenshot of my Visual Studio when I run it. This is since yesterday, and the problem goes away if I disable ReSharper:

Capture.PNG

0

I've checked the snapshots you've sent.
We have found the problem which causes stucks in typing, and we'll try to fix it in bugfix update.

Thank you.

0

I end up with uninstalling R#. It is cool, but it totally impossible to use R# with such scrolling and typing lags. After installing R# drops VS performance to netbook level.
It is impossible. Searches, navigating, building - everything becomes tooo slow. After uninstalling VS works well again. System monitor does not show significant difference.

I'm suspecting that R# somehow forces VS to wait for event handlers to complete and only then perform its own event handler. It does not look like something is loads CPU - something adds a delay.

Windows 7 Ultimate N x64, all updates, Visual Studio 2010 10.0.30319.1 + VisualSVN. Intel i7, 6GB RAM. Solution with 14 .NET 2.0 projects (class libraries and windows forms), about 2000 CS files. R# installed with default settings.

0

Same here. Unbelievably painful. 4GB of RAM and an SSD. And doesn't seem to be CPU either like Alex mentions. Scrolling, typing, doing anything... really slow with Resharper turned on.

0

Eugene

Glad you found the problem - just need to know about a ETA for this fix?  

<rant>You are frustrating and loosing loyal customers with R# behaving like it is.  This seems to be a recurring R# problem and even though I do have sympathy for the complexities that you guys need to cope with, I find a frustrating that with every new major R# release (and sometimes even with updates) we have to wait patiently for performance problems to be sorted out.  I'm glad you guys released R# so close to VS 2010 this time, but as all the other people on this forum have mentioned, the current R# is totally unusuable in VS2010.  Having gone through the same pains with R# 3.0 and R# 4.0 I am SO close to finally ditching R# and moving over to DevExpress Refactor Pro + CodeRush.  They don't seem to have the same kind of recurring performance problems as R# does. With their new unit test runner being added, they now contain all the essential features we need for our team.  Unfortunately we just spend a whole lot of money upgrading the team to R# so I probably won't be able to get money for doing this. From my perspective I would prefer less features in favour of a stable and "performing" R#.  Focus on making the current product offering work great instead of adding new features every time.</rant>

Regards

0

Please sign in to leave a comment.