Can I disable only the Resharper Editor Features?

Hello,

my solution is very big (about 135 projects). On my laptop is the performance of the editor with resharper to slow. But I like the great search features (e.g. type search), the are very fast anyway. So I want disable only the editor features of resharper, so that I can use the original VS Editor with the VS-Intellisense and VS-code analyse. I tried already to disable all Resharper code inspection features and switch the "Use IntelliSense" option to "Visual Studio", but this do not help enough.

regards,
michi!

2 comments

Hello Michael,

You can add the files where you do not need ReSharper's code analysis under
ReSharper | Options | Code Inspection | Settings -> Edit Items to Skip. Let
me know if this helps. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello,

my solution is very big (about 135 projects). On my laptop is the
performance of the editor with resharper to slow. But I like the great
search features (e.g. type search), the are very fast anyway. So I
want disable only the editor features of resharper, so that I can use
the original VS Editor with the VS-Intellisense and VS-code analyse. I
tried already to disable all Resharper code inspection features and
switch the "Use IntelliSense" option to "Visual Studio", but this do
not help enough.

regards,
michi!
---
Original message URL:
http://devnet.jetbrains.net/message/5305625#5305625



0

Hello,

As I had said already, I have disabled the code analyses complete, so the menu for skipping files is not available, but the editor is to slow.

I tried your suggestion anyway, so I enabled the code analyses, but the excluding of folder to not work (it' possible to select the folder, but it is not shown after the selection). Excluding 11000 files manually is not possible!

I do not want the resharper editor, I want the original editor of Visual Studio. I only want use the search features (e.g. type search).

Regards,
Michael Geramb

1

Please sign in to leave a comment.