Comment formatting with and without StyleCop plugin

I see different formatting during code cleanup, depending on whether the StyleCop plugin is installed or not.

Disabled:

    /// <summary>
    ///     Class which represents ...
    /// </summary>


Enabled:
    /// <summary>
    /// Class which represents ...
    /// </summary>


I'm a bit confused by this.
5 comments

And now I'm seeing those extra spaces at the beginning of the comment being added no matter whether the plugin is enabled or not.

It seems to be adding four spaces to the beginning of each comment summary, which is very much NOT what I want.

0

Hello,

Do I understand correctly that comments are added whenever you run Code Cleanup
with 'Reformat embedded xml comments' enabled? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I see different formatting during code cleanup, depending on whether
the StyleCop plugin is installed or not.

Disabled:
/// <summary>
///     Class which represents ...
/// </summary>
Enabled:
/// <summary>
/// Class which represents ...
/// </summary>
I'm a bit confused by this.

---
Original message URL:
http://devnet.jetbrains.net/message/5305561#5305561



0

No. I'm saying that existing comments are reformatted with additional spaces between the trailing slash and the head of the text.

/// <summary>
/// Comment
/// </summary>

Becomes,

/// <summary>

///    Comment

/// </summary>

And I'd like to know where I can manage the setting that adds/removes those spaces.

0

Here's my configuration:

JetBrains ReSharper 5.1 Full Edition
Build 5.1.3000.12 on 2011-01-28T05:05:56

Licensed to: G. Richard Bellamy
Plugins: 3
#1. “Settings Manager” v3.0.0.0 by “Roman "4ux-nbIx" Novitsky”
#2. StyleCop v4.5.16.0 by http://stylecop.codeplex.com
#3. “xUnit.net unit test provider for ReSharper 5.1” v0.4.1.1709 by “xunitcontrib Team”
Visual Studio 10.0.40219.1.

Copyright © 2003–2011 JetBrains s.r.o.. All rights reserved.


And attached you can see that I've disabled the StyleCop plugin.

Attached also find a screencast of what I'm seeing happen.


Attachment(s):
ScreenCapture_6-11-2011 8.31.18 AM.wmv.zip
Plugins_2011-06-11_08-36-02.png
0

Could someone give me a hand here - it's getting really old having to go back through and remove these extra spaces.

0

Please sign in to leave a comment.