Purchasing upgrade on website doesn't work

How on earth does one purchase an upgrade on the website!?

I click on 'Upgrading user' tab. I make my selections. I click on 'upgrade now'. I enter my license key. I get a big message that says my cart is empty plus a list of recommended products! Only Full edition commercial vewrsion of R# for $349.00 is my R# choice. When I try again from the beginning, I never get the page to enter my license key again. I tried two different computers. Somewhere after entering the license key the process went bezerk.

Either I am doing it wrong or there's something wrong with the site.

5 comments

abdu,

Please make sure that JavaScript is enabled for ReSharper web site.
The problem you're describing is very similar to the one other users have had without JavaScript support enabled.
The price and the upgrade link that you're getting when you select items from drop-downs are both driven by JavaScript. If JS is off, nor the price neither the upgrade link change, leaving you with the default option of commercial upgrade. When you click the commercial upgrade link, our e-shop expects to receive an existing commercial license but you are naturally entering your personal license. At this point, e-shop is going crazy and gets you an empty card without any error messages (this is a known bug.)
If enabling JavaScript doesn't solve the issue, let me know which selections you're making in the three drop-down lists, and I'll provide you with a direct upgrade link.

0

I have used three different browsers and two different computers in two different networks. I don't turn my javascript off (otherwise the web is broken for me!)
After all these tries, I have to conclude the problem is at Jetbrains side. The rest of the web works fine for me!

Anyways, I did the upgrade through on of the sales people.

Thanks.

0

Thanks for getting back, and sorry for the bad experience you've had with our e-shop.
However, we're unable to reproduce it on our side.
Having your old license certificate (the one containing your old license key that you were entering in the e-shop upgrade page) could help us find out what was going wrong, so if you want, you can send it to me (Jura.Gorohovsky at jetbrains.com) for further investigation: This would hopefully help prevent similar issues with other customers.
Thank you!

0

I have exactly the same problem. I have tried to upgrade on multiple platforms and browsers and after entering the upgrade code, it takes me to an empty cart with no option to purchase an upgrade.

I will send my license key in a private email.

0

It's an issue with the site. They're looking into it.

0

Please sign in to leave a comment.