Script Documents error

Hello,

I'm using ReSharper 4.5 C# Edition for my ASP.NET web application in Visual Studio 2008.

When I start debugging my web site, the solution-wide analysis button at the lower right of my screen turns red, showing '1 file with errors'. When I click 'Show Errors View', I get the following error: 'Script Documents (in <Script Documents>) - File is missing'. No more information about the error is shown, so I can't find out what file ReSharper is missing.

I think it has something to do with the 'Script Documents' node under which all dynamically generated runtime files are shown in Visual Studio 2008 Solution Explorer, but I don't see any broken links there. My web application seems to work ok.

What's the cause of this error that ReSharper notifies me about?

Kind regards,
Jeroen

4 comments

Jeroen,

Is it possible to strip your website down to a small sample that reproduces the problem and mail it us for investigation?
Thanks in advance.

0

I'm having the exact same issue in Visual Studio 2010 with both ReSharper 5.1 and ReSharper 6.0.2202.688 that I've just upgraded today. As soon as you debug (F5) the solution, the solution-wide analysis turns red with a single error: "1 file with error"  "<Script Documents>\Script Documents (1 error) - File is missing". When you stop debugging, the solution-wide analysis turns green.

I'm attaching a repro solution for your analysis.



Attachment(s):
SolutionErrorOnDebug.zip
0

Hello Allon,

I'm afraid I couldn't reproduce this behavor with the sample solution. Could
you please attach a screenshot of the Errors in solution window demonstrating
this error? Also, could you please check if this happens on your machine
only or on colleague's machines as well? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I'm having the exact same issue in Visual Studio 2010 with both
ReSharper 51 and ReSharper 6.0.2202.688 that I've just upgraded today.
As soon as you debug (F5) the solution, the solution-wide analysis
turns red with a single error: "1 file with error"  "<Script
Documents>\Script Documents (1 error) - File is missing". When you
stop debugging, the solution-wide analysis turns green.

I'm attaching a repro solution for your analysis.

---
Original message URL:
http://devnet.jetbrains.net/message/5313098#5313098



0

This happened on my previous machine and on my current machine, and I've now tested it on a coworker's machine and it happens there too.

This wouldn't be such a nuisance if ignoring the error would persist between debug sessions, but even if you ignore the error it comes back every time you press F5.

Attached are screenshots before and after I press F5.



Attachment(s):
SolutionErrorOnDebug-AfterF5.png
SolutionErrorOnDebug-BeforeF5.png
0

Please sign in to leave a comment.