ReSharper 6 js Intellisense bug

my envirement : windows7 sp1 + vs2005 + ReSharper 6

when i press enter button in js function in javascript file[test.js], R#6  will add "foo" automately after the new line (attachment below)


is it normal?

but when i do this in other file types like (aspx.....),it works well.



Attachment(s):
捕获.PNG
7 comments

Hello,

Do I understand correctly that this doesn't happen when ReSharper is suspended
under Tools | Options | ReSharper | General? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

my envirement : windows7 sp1 + vs2005 + ReSharper 6

when i press enter button in js function in javascript file[test.js],
R#6  will add "foo" automately after the new line (attachment below)

is it nomal?

but when i do this in other file types like (aspx.....),it works well.

---
Original message URL:
http://devnet.jetbrains.net/message/5311896#5311896



0

I haven't seen this behavior yet, but I have seen some really odd ReSharper
completion behavior in javascript files. It's weird because ReSharper will
randomly add () to a property on completion and will occasionally complete
with something different than what I typed.

The completion behavior in control attributes doesn't quite work correctly
in aspx pages, either. I can type  two or three times to finally get a
dropdown.

Now you have <asp:TextBox ID="foo" so add Enabled= and you'll get
<asp:TextBox ID="foo" Enabled="|" where | is the cursor but no intellisense.
Type TextMode="" and I get an odd intellisense completion list seems
irrelevant for valid TextMode values. I attached a screenshot showing the
completion list.

The remaining intellisense issue is that ReSharper very rarely shows
intellisense when typing the name of a control or class instance in a
code-behind file. This may be related to the size of the solution, but I can
type foo (knowing foo is the textbox above) and wait. Most of the time
ReSharper's intellisense pops up long after I've typed the name of the
control or class. Randomly it won't pop up at all. If I type foo.t,
ReSharper usually pops up the intellisense list for the properties and
methods of the control or class fairly quickly.

I hope this helps.


"y z"  wrote in message
news:16102516.369771311152436868.JavaMail.devnet@confluence.jetbrains.net...

my envirement : windows7 sp1 + vs2005 + ReSharper 6

when i press enter button in js function in javascript file[test.js], R#6
will add "foo" automately after the new line (attachment below)


is it nomal?

but when i do this in other file types like (aspx.....),it works well.

---
Original message URL: http://devnet.jetbrains.net/message/5311896#5311896



Attachment(s):
ReSharper 3.png
0

yes, that's right.

the problem only happen when ReSharper6 is enabled

is it a bug?

if you need some detail ,i am here


thank you for your response.

0

Hello,

I'm afraid I couldn't reproduce this behavior. Does this happen in standalone
.js files or within tags as well? Does this happen in newly created
web application projects as well? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

yes, that's right.

the problem only happen when ReSharper6 is enabled

is it a bug?

if you need some detail ,i am here

thank you for your response.

---
Original message URL:
http://devnet.jetbrains.net/message/5312963#5312963




0

This problem only appears to happen when editing .js files that aren't in the VS project.  When editing .js files in a project, the problem does not occur.

Steps to reproduce:

  • Open a project with .js files
  • In the Solution Explorer enable "Show all Files" to see files that aren't part of projects
  • In the Solution Explorer, right-click on that file and select "Exclude from Project" (VS will close the file)
  • In the Solution Explorer, double-click the excluded .js file to open in the VS editor
  • Place you cursors at the end of a line
  • Hit <Enter>
  • You'll have created a new line and the cursor will have the word "foo" to it's right

  • This problem does not occur if you hit enter while the cursor is in the middle of a line
  • This problem does not occur on the last line in the document
0

I do reproduce the same behavior.
Win 7 + VS 2010 + R# 6

0

Hello Stepan,

Thank you! I was able to reproduce this behavior and you're welcome to vote
for the following bug-report: http://youtrack.jetbrains.net/issue/RSRP-274602.


Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Steps to reproduce:

  • Open a project with .js files

  • In the Solution Explorer enable "Show all Files" to see files that

aren't part of projects

  • In the Solution Explorer, right-click on that file and select

"Exclude from Project" (VS will close the file)

  • In the Solution Explorer, double-click the excluded .js file to open

in the VS editor

  • Place you cursors at the end of a line

  • Hit <Enter>

  • You'll have created a new line and the cursor will have the word

"foo" to it's right

  • This problem does not occur if you hit enter while the cursor is in

the middle of a line * This problem does not occur on the last line in
the document



0

Please sign in to leave a comment.