Missing Find Usages shortcut

I am using the VS keymap in ReSharper 6 (6.0.2202.688) and the Find Usages shortcut (Shift+F12) does not work.

If I switch to the IDEA keymap the shortcut (Alt+F7) works fine.

Switching back to the VS keymap didn't fix the problem. I've even gone into Tools | Options | Environment | Keyboard and reset the VS keyboard mapping (and then applied the VS keymap). All to no avail.

I've had to manually set the shortcut for "ReSharper.ReSharper_FindUsages". Now it works.

Is this an "undocumented feature" with ReSharper?

3 comments

The same issue exists with "ReSharper.ReSharper_GotoDeclaration". I had to manually set it to F12.

0

Hello William,

Could you please perform an experiment:
1. Reset the keyboard scheme under Tools | Options | Environment | Keyboard
(to Visual Studio 2005)
2. Re-apply the Visual Studio scheme under ReSharper | Options | Visual Studio
Integration
3. Make sure that Shift+F12 is mapped to 'Edit.FindAllReferences' command
both in 'Global' and 'Text Editor' contexts
4. Check if Shift+F12 works.

Let me know the results. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

The same issue exists with "ReSharper.ReSharper_GotoDeclaration". I
had to manually set it to F12.

---
Original message URL:
http://devnet.jetbrains.net/message/5317782#5317782



0

It works.

When I look at the mapping though, Shift+F12 is only mapped "Global" (not in "Text Editor").

I think the issue occurred because I toggled between ReSharper keyboard schemes (Visual Studio and IDEA).

Thanks!

BTW... if I change the drop-down in Tools | Options | Environment | Keyboard to "Default", the mapping disappears. The if I change the drop-down to "Visual Studio 2005" the mapping is still not in the list.

0

Please sign in to leave a comment.