smart completion in object intializer doesn't work

It doesn't work (ctrl+shift+space). (Or else it's working and I need a picture of what it's supposed to look like.)
There is only a tip box saying "use smart completion to show all" but that's it. The tip box blocks my keyboard typing, so I am getting negative productivity since I have to hit escape all the time to get rid of it.


http://www.jetbrains.com/resharper/webhelp/Coding_Assistance__Code_Completion__Smart.html#object_initializer

On this page, in the "In Object Intializers" section, I don't get the intellisense box you show.

8 comments
Comment actions Permalink

Hello Paul,

Do I understand correctly that invoking ReSharper | Edit | Smart Code Completion
in this case doesn't show any list? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

It doesn't work.
There is a tip saying "use smart completion to show all" but that's
it.
---
Original message URL:
http://devnet.jetbrains.net/message/5362796#5362796



0
Comment actions Permalink

I have not been using the resharper menus. The menu item works and there is a list.

Ctrl+shift+space does not work and would like to know why.

I recommended something like intellisense to microsoft about a year before they implemented it in visual studio. They needed something to replace the copy/paste of APIs from help (that everyone was doing) that they broke somewhat in a newer version. My idea then, and now, is that the popup window could be actually be used to insert prototype text into your file. So when you are editing in an object initializer block for example, there would be an affordance to insert all the members automatically. This would really save time. It's not very productive for me to seach through menus for a list, and for every member.

0
Comment actions Permalink

Can you confirm in Visual Studio under Tools | Options | Keyboard there is a mapping for ReSharper.ReSharper_CompleteCodeSmart is mapped to Ctrl + Alt + Space?

2
Comment actions Permalink

No, there is no mapping for ReSharper.ReSharper_CompleteCodeSmart at all and I don't see a way to add it. Reinstall resharper?

0
Comment actions Permalink

Go to ReSharper | Options | Visual Studio Integration and under Keyboard Shortcuts select "Visual Studio" and then press Apply Scheme.

If that was already selected, then select None and press Apply Scheme then press Cancel. Go to Tools | Options | Environment | Keyboard and reset your keyboard mappings (assuming you haven't made any custom mappings already, if you have you will need to recreate them). After that, go to ReSharper | Options | Visual Studio Integration and under Keyboard Shortcuts select "Visual Studio" and then press Apply Scheme.

1
Comment actions Permalink

Ok, it's working now thanks.


0
Comment actions Permalink

This page says it's ctrl-shift-space.

http://www.jetbrains.com/resharper/webhelp/Coding_Assistance__Code_Completion__Smart.html

But it's really ctrl-alt-space, once I had the keyboard shortcuts reset.

0
Comment actions Permalink

Hello Paul,

At the moment the web help for ReSharper shows shortcuts for 'ReSharper 2.x
or IntelliJ IDEA' keyboard scheme, while you're using 'Visual Studio' keyboard
scheme. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

This page says it's ctrl-shift-space.

http://www.jetbrains.com/resharper/webhelp/Coding_Assistance__Code_Com
pletion__Smart.html

But it's really ctrl-alt-space, once I had the keyboard shortcuts
reset.

---
Original message URL:
http://devnet.jetbrains.net/message/5371040#5371040



0

Please sign in to leave a comment.