Resharper 6 unit tests not running in visual studio 2010

Hey,

I'm just trialing resharper at the moment and am having a problem with the unit test runner. Every time I try and run a test the session window pops up but the test doesn't run. This is the same for single tests or group of tests any way I run them.

It just seems to hang with the progress bar turning over (See the upload)

Has anybody experienced this or does anybody know of anything that can help me figure out what is wrong.

I've turned all the other addins and extensions I use but the problem still exists so I would think its not a confliction problem.

Thanks in advance.



Attachment(s):
Untitled.png
6 comments

I experienced similar when for tests deriving from a generic base class. Doubtful if that is your issue though ( http://youtrack.jetbrains.net/issue/RSRP-273687 "Unit test runner shows inconclusive with test class with generic base class" ).

0

Thanks for replying, but no this is not the same issue

0

Mathew,

Could you please create a simple solution for us which could demonstrate strange behavior? Thanks in advance!

Kirill Falk

0

Hey,

I set up a test project and the unit testing worked fine. It would seem that this is a problem with one of my solutions.

Hmm, this could take some digging. If anybody has any suggestions or knows how I can turn some debug on to check where the problem is that would be great.

Cheers
Mat

0

Did you ever figure out what the issue was?

0

We are also having issues on projects recentl upgraded from VS2008SP1 to VS2010SP1 (for what its worth the projects were all retargeted back from .NET 4.0 to 3.5 after the migration wizard).

Theres another thread outlining some issues ocurring when using the R# 6.x test runner against VS2010(SP1?) projects:
http://devnet.jetbrains.net/message/5447559

0

Please sign in to leave a comment.