Missing XML comment for publicly visible type or member

Answered

Hi,

I configured my Resharper to force me to add XML comments for all my public types and members.
So I should get an error if I don't put it.
That worked for some time. But now it stopped working.
The settings are still the same.

Could somebody point me into the right direction please?
All other things in resharper seem to be working just fine.

Kind Regards
Tim

3 comments
Comment actions Permalink

Go to your project Properties --> tab Build.

Check if "XML documentation file" is checked. If not, it won't give you any errors or warnings.

0
Comment actions Permalink

Thanks. That solved the issue.

0
Comment actions Permalink

Hi,

I've configured ReSharper to produce a compiler error if public methods aren't Xml documented (Code Inspection > Inspection Severity > C# > Compiler Warnings > CS1591: Missing XML comment for publicly visible type or member > Error), but it doesn't produce any compiler error when I build in VS 2015 unless I also check boxes: VS Project > Properties > Build > Output > 'Xml documentation file' and also Treat warnings as errors > Specific warnings > CS1591.

Intuitively you'd think that the ReSharper setting would be enough to fail a build without having to also configure the extra steps in the VS build properties; why is this not the case?

Thanks,
Conrad

0

Please sign in to leave a comment.