SA1633 - Insert/replace header no longer shows as a "quick fix" action

I'm not sure when it happened as I've not created that many new classes recently (and when I did I was too busy to look into why this no longer worked), but a few versions ago of Resharper/StyleCop (for resharper) if you created a new class file and omited a file header comment block at the top and had SA1633 (FileMustHaveHeader) enabled in StyleCop, you got a quick fix helper like the one in this screenshot
http://blogs.jetbrains.com/dotnet/wp-content/uploads/2010/12/image-thumb15.png

(screenshot taken from the Resharper blog page: http://blogs.jetbrains.com/dotnet/2010/12/automating-file-header-information-with-resharper/)

(Similarly, if the company name or copyright notice did not match the StyleCop company name/copyright notice I believe there was a quick fix that fixed that up for you)

Has this been removed, or has my installation gone awry?
If it's been removed, can I assume it was for technical reasons and it is slated to come back?
If it is my installation, does anyone know how I can resolve it?
Or should I be asking this on the StyleCop forums instead? (I don't think so as StyleCop is more about reporting the problems than fixing them, but I may be wrong)

I'm hoping it's still there and it's just a problem with my installation. I've even tried reinstalling both R# and StyleCop just in case that fixed it, but alas no!

BTW I know it's possible to add/update the header using a Code Cleanup, but I don't really want to perform a full code cleanup just to add/update a file header when a simple Alt-Enter, Enter used to do it (and without the fear of it also trampling over other aspects of your code)

Thanks


Chris

Resharper version: 6.1.1000.82 (C# Edition)
StyleCop version: v4.7.1000.0

2 comments
Comment actions Permalink

Hi there! In this case you should definitely be asking on the StyleCop forums, as the functionality you mention isn't part of ReSharper. I doubt that R#'s Code Cleanup feature for the file header and StyleCop's one are in any way related, but even if they are, it is still StyleCop that provides the context action for this feature.  Dmitri

0
Comment actions Permalink

Thank you Dmitri - I'll do that (or will even examine the code myself seeing as it's on codeplex - because it used to be in there, so it's probably justnot firing for some reason)

0

Please sign in to leave a comment.