Not integrated with VS 2010 after install

I've been running into a problem installing 5.1.1727.12.  I'm running Windows 2008 Server R2 in some sort of lowered-privledges mode (implemented by the IT department).  When I install R# it tells me it succeeded; but when I run VS 2010 there is neither a Resharper menu in the main menu (before or after loading a solution) not a Resharper entry in the Tools/Options tree.

I've also got VS 2008 installed and that integration worked fine.

I've tried repair, full uninstall/reinstall, change install unchecking VS 2010 and change re-checking VS 2010.  No order seems to make a difference.

Any suggestions?

Thanks -- Peter

15 comments
Comment actions Permalink

Hello Peter,

Could you please attach a screenshot of Tools | Extension Manager? Is there
a chance that you could re-install ReSharper under an account with administrative
rights? Thank you!

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I've been running into a problem installing 5.1.1727.12.  I'm running
Windows 2008 Server R2 in some sort of lowered-privledges mode
(implemented by the IT department).  When I install R# it tells me it
succeeded; but when I run VS 2010 there is neither a Resharper menu in
the main menu (before or after loading a solution) not a Resharper
entry in the Tools/Options tree.

I've also got VS 2008 installed and that integration worked fine.

I've tried repair, full uninstall/reinstall, change install unchecking
VS 2010 and change re-checking VS 2010.  No order seems to make a
difference.

Any suggestions?

Thanks -- Peter

---
Original message URL:
http://devnet.jetbrains.net/message/5270330#5270330



0
Comment actions Permalink

Hy Andrey.  The currently logged on user is in the Administrators group on the computer.  As
far as I know there is required to execute an MSI.

I've just downloaded 5.1.1742.13 and installed that (letting it remove the previous version) and that doesn't solve the problem.

The following is a screen shot of the extension manager in Visual Studio 2010:
extmgr.png
The following is the R# "change" uninstall screen (without pressing "Install") showing that both integration into 2008 and 2010 is enabled:
resharper setup.png
Thanks -- Peter

marcus23 wrote:

Hello Peter,

Could you please attach a screenshot of Tools | Extension Manager? Is there
a chance that you could re-install ReSharper under an account with administrative
rights? Thank you!

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I've been running into a problem installing 5.1.1727.12.  I'm running
Windows 2008 Server R2 in some sort of lowered-privledges mode
(implemented by the IT department).  When I install R# it tells me it
succeeded; but when I run VS 2010 there is neither a Resharper menu in
the main menu (before or after loading a solution) not a Resharper
entry in the Tools/Options tree.

I've also got VS 2008 installed and that integration worked fine.

I've tried repair, full uninstall/reinstall, change install unchecking
VS 2010 and change re-checking VS 2010.  No order seems to make a
difference.

Any suggestions?

Thanks -- Peter

---
Original message URL:
http://devnet.jetbrains.net/message/5270330#5270330



0
Comment actions Permalink

I've been digging into this problem further and this is what I've come up with so far:  Visual Studio is confirming successful load of the Resharper 5.1 extension and it has been successfully enabled (but no "Reshaper" appears in menu, no "Reshaper" appears in Tools/Options and no changes to the IDE--no context action icons displaying and no marker bar displaying).

VS goes on to detail that both C:\Program Files  (x86)\JetBrains\ReSharper\v5.1\Bin\JetBrains.Platform.ReSharper.VsIntegration.DevTen.dll and C:\Program Files  (x86)\JetBrains\ReSharper\v5.1\Bin\JetBrains.ReSharper.VS.DevTen.dll were successfully loaded from cache.

There are no errors from VS regarding Resharper...

0
Comment actions Permalink

Hello,

Visual Studio is confirming successful load of the
Resharper 5.1 extension


The extension is not the main part, it's just for highlightings in the editor
and the error stripe. What matters most is the Visual Studio ReSharper package.
Visual Studio startup logs could mention it by name or GUID, {0C6E6407-13FC-4878-869A-C8B4016C57FE}.
Is it there?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

baltic wrote:


Visual Studio startup logs could mention it by name or GUID, {0C6E6407-13FC-4878-869A-C8B4016C57FE}.
Is it there?


Hi Serge, there's no mention of {0C6E6407-13FC-4878-869A-C8B4016C57FE} when running "devenv /log"

Thanks -- Peter

0
Comment actions Permalink

I have exactly the same problem. I had to re-install ReSharper (version 5.1.1753.4), but it does not appear in Visual Studio 2010. It is not visible in the Add-In Manager, and the ReSharper menu is not visible.

In the ActivityLog.xml (starting devenv.exe /log) I can see, that it loaded ReSharper successfully, but I cannot see it anywhere. Anyone any ideas?

  <entry>
    <record>82</record>
    <time>2010/10/30 20:21:21.328</time>
    <type>Information</type>
    <source>Extension Manager</source>
    <description>Successfully loaded extension...</description>
    <path>C:\Program Files (x86)\JetBrains\ReSharper\v5.1\Bin\</path>
  </entry>
  <entry>
    <record>83</record>
    <time>2010/10/30 20:21:21.329</time>
    <type>Information</type>
    <source>Extension Manager</source>
    <description>Extension is enabled...</description>
    <path>C:\Program Files (x86)\JetBrains\ReSharper\v5.1\Bin\</path>
  </entry>
  <entry>
    <record>154</record>
    <time>2010/10/30 20:21:21.508</time>
    <type>Information</type>
    <source>Microsoft.VisualStudio.CommonIDE.ExtensibilityHosting.VsShellComponentModelHost</source>
    <description>Successfully loaded component assembly from cache</description>
    <path>C:\Program Files (x86)\JetBrains\ReSharper\v5.1\Bin\JetBrains.Platform.ReSharper.VsIntegration.DevTen.dll</path>
  </entry>
  <entry>
    <record>155</record>
    <time>2010/10/30 20:21:21.509</time>
    <type>Information</type>
    <source>Microsoft.VisualStudio.CommonIDE.ExtensibilityHosting.VsShellComponentModelHost</source>
    <description>Successfully loaded component assembly from cache</description>
    <path>C:\Program Files (x86)\JetBrains\ReSharper\v5.1\Bin\JetBrains.ReSharper.VS.DevTen.dll</path>
  </entry>

0
Comment actions Permalink

Hello Matthias,

Is there a ReSharper tab under Tools | Options? Is ReSharper listed among
installed products under Help | About Visual Studio? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I have exactly the same problem. I had to re-install ReSharper
(version 5.1.1753.4), but it does not appear in Visual Studio 2010. It
is not visible in the Add-In Manager, and the ReSharper menu is not
visible.

In the ActivityLog.xml (starting devenv.exe /log) I can see, that it
loaded ReSharper successfully, but I cannot see it anywhere. Anyone
any ideas?

<entry>
<record>82</record>
<time>2010/10/30 20:21:21.328</time>
<type>Information</type>
<source>Extension Manager</source>
<description>Successfully loaded extension...</description>
<path>C:\Program Files (x86)\JetBrains\ReSharper\v5.1\Bin\</path>
</entry>
<entry>
<record>83</record>
<time>2010/10/30 20:21:21.329</time>
<type>Information</type>
<source>Extension Manager</source>
<description>Extension is enabled...</description>
<path>C:\Program Files (x86)\JetBrains\ReSharper\v5.1\Bin\</path>
</entry>
<entry>
<record>154</record>
<time>2010/10/30 20:21:21.508</time>
<type>Information</type>

<source>Microsoft.VisualStudio.CommonIDE.ExtensibilityHosting.VsShellC
omponentModelHost</source>
<description>Successfully loaded component assembly from
cache</description>
<path>C:\Program Files
(x86)\JetBrains\ReSharper\v5.1\Bin\JetBrains.Platform.ReSharper.VsInte
gration.DevTen.dll</path>
</entry>
<entry>
<record>155</record>
<time>2010/10/30 20:21:21.509</time>
<type>Information</type>

<source>Microsoft.VisualStudio.CommonIDE.ExtensibilityHosting.VsShellC
omponentModelHost</source>
<description>Successfully loaded component assembly from
cache</description>
<path>C:\Program Files
(x86)\JetBrains\ReSharper\v5.1\Bin\JetBrains.ReSharper.VS.DevTen.dll</
path>
</entry>
---
Original message URL:
http://devnet.jetbrains.net/message/5276464#5276464



0
Comment actions Permalink

No, it is NOT listed in Tools --> Options
And it is also NOT listed in Help --> About Visual Studio

But in the ActivityLog is says, that it was loading successfully.

Tried to uninstall and reinstall now the 5th time with no changes. It simply does not appear in Visual Studio.
I also tried to remove the registry keys after uninstall, but again no change.

0
Comment actions Permalink

I now found the source of the problem:

Two weeks ago I had installed the free version of the virus scanner "ThreatFire" (http://www.threatfire.com) after some positive articles in some magazines. The virus scanner has an integrated behavior analysis to detect viruses. And it seems that ThreatFire recognized ReSharper as a virus, but it never poped up a message or warning, it just disabled parts of it.


After uninstalling ThreatFire, everything was working fine again.

0
Comment actions Permalink

Hello Matthias,

Thank you for this information! I've added a case to our installation problems
troubleshooting guide at http://devnet.jetbrains.net/docs/DOC-1222.

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I now found the source of the problem:

Two weeks ago I had installed the free version of the virus scanner
"ThreatFire" (http://www.threatfire.com/) after some positive articles
in some magazines. The virus scanner has an integrated behavior
analysis to detect viruses. And it seems that ThreatFire recognized
ReSharper as a virus, but it never poped up a message or warning, it
just disabled parts of it.

After uninstalling ThreatFire, everything was working fine again.

---
Original message URL:
http://devnet.jetbrains.net/message/5276802#5276802



0
Comment actions Permalink

I had the same problem, VS2010 and version 5.1.1753.4 of ReSharper.  After multiple install/uninstall/register MSXML6/attempts, I finally figured out that:

A REINSTALL DOESN'T AUTOMATICALLY RE-ENABLE RESHARPER IF IT WAS DISABLED AT THE TIME OF DEINSTALLATION!

So the simple fix is just got to Tools.Options.ReSharper.General in VS2010 and enable it again.

0
Comment actions Permalink

This sounds similar to the problem I am having,

I installed ReSharper Beta 6.0.2165.98 and it was working fine.  I updated to 6.0.2168.356 when prompted.  It appeared to install correctly, but ReSharper is now missing from VS2010.  There is no menu item for ReSharper and does not appear in Options. It is not in the Extensions Manager, it is not in Help > About.

I ran devenv /Log and I can see no attempt to load anything to do with ReSharper.

Any ideas of what I can try?

Cheers,
Michael

[EDIT:  Should also mention that I have tried to install the RC 6.0.2171.226 version with the same result.]

0
Comment actions Permalink

I'm having the same issue.  Resharper installs, fine, but it is nowhere to be found on any menu.  How do I fix this?

0
Comment actions Permalink

Hello William
     Have you tried following the steps from this troubleshooting article: http://devnet.jetbrains.com/docs/DOC-1222?

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

Yes I did.  That was not it.  After re-booting about 3 times, it
finally showed up.

0

Please sign in to leave a comment.