Resharper EAP 7 OutOfMemoryException with large XML files in solution

In our projects we have some quite large XML data files. Resharper insists on processing these files when opening the solution, leading to an OutOfMemoryException. As a result, we have supended Resharper in order to open the solution. Is there some way to disable file processing when solutions load in Resharper, or is this some kind of bug?

1 comment
Comment actions Permalink

If you do not mind not processing any XML file, you add *.xml to the Generated files masks ( Resharper -> Options -> Generated Code -> Generated file masks ).  This should stop the analysis of all XML files - including the large ones.

HTH

David

0

Please sign in to leave a comment.