Problem with SDK Sample

Hi

I have some problem with the SDK sample
I build all of them in VS2012 and copied dlls to C:\Users\jod\AppData\Local\JetBrains\ReSharper\vAny\Plugins

Several things happened
* VS2010 the "ReSharper > Power Tools" works fine
* VS2012 the "ReSharper > Power Tools" is greed out
     Am I missing some configuration differences here?
* VS2010 + VS2012 my context menu got redefined e.g. "Find Usage", "Find Usage Advance" and several other entries disapeared, looks like it was force away from showing both the old VS and the new R# entries toward replece VS with R#
     Are there any way to go back and have both VS and R# menu entries?

versions info:

JetBrains ReSharper 7.0.1 C# Edition
Build 7.0.1098.2760 on 2012-08-27T14:31:12

Licensed to: Develco A/S
Plugins: 9
#1. “ReSharper PowerToys: Cyclomatic Complexity” v3.0.0.0 by “JetBrains s.r.o.”
#2. “ReSharper PowerToys: Explore Type Interface” v3.0.0.0 by “JetBrains s.r.o.”
#3. “ReSharper PowerToys: Generate Dispose” v1.0.0.0 by “JetBrains s.r.o.”
#4. “ReSharper PowerToys: Gist” v1.0.0.0 by “JetBrains s.r.o.”
#5. “ReSharper PowerToys: Current File Path Macro” v3.0.0.0 by “JetBrains s.r.o.”
#6. “ReSharper PowerToys: Make Method generic refactoring” v3.0.0.0 by “JetBrains s.r.o.”
#7. “ReSharper PowerToys: Sample Menu Items” v3.0.0.0 by “JetBrains s.r.o.”
#8. “ReSharper PowerToys: Sample Options Page” v3.0.0.0 by “JetBrains s.r.o.”
#9. “ReSharper PowerToys: FindText” v3.0.0.0 by “JetBrains s.r.o.”
Visual Studio 11.0.50727.1.

Copyright © 2003–2012 JetBrains s.r.o. All rights reserved.

1 comment
Comment actions Permalink

Could you check in the plugins folders to see if there are any JetBrains*.dll files? They shouldn't be copied into the bin directories, but I just built the samples and I got a couple. That could be causing problems (you could end up with two versions of the same assembly loading, and that would cause issues with type equality, and probably throw exceptions. This could be causing the plugins to fail, and be why the menu item is greyed out - if no plugins are avaiable, the menu item is greyed)

Failing that, it should just be a case of deleting plugins until everything works again.

Let me know how you get on
Matt

0

Please sign in to leave a comment.