Ctrl+Shift+Space Doesn't display the Parameter Info in Visual Studio 2012.

I'm testing the new release of Resharper but I have some problem with hotkeys.
Currently I'm using the "Visual C# 2005" keyboard scheme in VS2012 and in the Resharper settings, for the keyboard shortcuts, I'm using the Visual Studio schema.

The problem is that Ctrl+Shift+Space doesn't display the Parameter Info in the editor. This shortcut works only if I disable the Resharper.

9 comments
Comment actions Permalink

Hello Luigi,

ReSharper has  its own parameter information function, which can be used in "Resharper | Edit | Parameter Info" main menu command. Shortcut for VS scheme is Ctrl+P by default, but you may remap it in the "Tools | options | environment | keyboard" dialog.

Thanks.

0
Comment actions Permalink

Thanks for your answer but... I tried to assign the same shortcuts for the Edit.ParameterInfo (default Ctrl+Shift+Space) to the command ReSharper.Resharper_ParameterInfo_Show as you have suggested, but the result is the same.
key01.jpg
I'm not able to show the Parameter info tooltip with the Resharper addin enabled.

I tried many times to re-apply the keyboard schema from VS options and also from Resharper options, but the result it's the same, not works.
Have you any other suggestions?

0
Comment actions Permalink

Luigi,

I've tried to reapply shortcut and it is working fine for me on ReSharper 7.1 and VS2012.
Can you try to use the menu command (not a shortcut) to show Parameter Info to check if it's actually working?

Please let me know how it goes.
Thank you.

0
Comment actions Permalink

Unfortunately also with the menu I don't see any tooltip with the parameter info.
If I suspend the Resharper, I can see again the tooltip.

Have you any suggestion to reset all the settings of the Resharper and/or the VS2012?

I can try to export the current configuration, reset all the settings, and try again to show the parameter info with the Resharper active.

0
Comment actions Permalink

Luigi,

Could you please enable ReSharper back and check the Parameter Info settings in R# Options? I've attached a screen for a reference.

Thanks!



Attachment(s):
screen374.png
0
Comment actions Permalink

I have all the settings disabled!
(in the IntelliSense\General page I have selected "Visual Studio" for the 'Use IntelliSense (...) feature of:')

If I select the option "Resharper", now I see the tooltip but in the 'Resharper' style and not in the Visual Studio style.
With the release 7.0 I was able to use the "Visual Studio" option for the IntelliSense, without problems.

I don't like the Resharper Intellisense style (sorry :) ).
Is it possible to enable again the functionality as the previous version (Visual Studio style but with also the Ctrl+Shit+Space enabled).

PS: Sorry for my english.

0
Comment actions Permalink

Hello Luigi,

Thanks for a detailed description. I should've asked if you are using R# or native VS Intellisense. I've confirmed this issue as a bug and opened a request to fix it here: http://youtrack.jetbrains.com/issue/RSRP-335798.

0
Comment actions Permalink

Hello Alex, thanks

If you want I have also the log file (but probably it is not necessary).



Attachment(s):
resharper_log.zip
0
Comment actions Permalink

Yeah, thanks for the log!

0

Please sign in to leave a comment.