IntelliSense randomly stops automatically displaying (Resharper 6)

Randomly, IntelliSense will stop automatically displaying in C# files (when "." is pressed, or just typing). Ctrl-Space will still bring it up, but I find that to be too much work.  If I close the file and re-open it, IntelliSense again works as expected.  

If i had to make a guess, I think it usually happens after their are some errors in the file, like the parsing of the file fails and then never recovers, even after the errors are fixed.

(I'm using VS2010, Resharper 6.1)

Anyone else experience this?

55 comments
Comment actions Permalink

I get this about once or twice a day for no obvious reason.  Closing/opening VS.NET usually fixes it for me.  WIll try just closing the file and/or solution in future and report back.

0
Comment actions Permalink

Same here, have to restart VS. Annoying.

0
Comment actions Permalink

Hello
     Could you please run Visual Studio (devenv.exe) with /ReSharper.LogFile "C:\log.txt" /ReSharper.LogLevel Verbose command line parameters and attach the resulting log files here after IntelliSense stops displaying automatically? Thank you!

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

Ok - have done this - and haven't experienced this bug since :)

If it happens again I'll upload the log.

Cheers,

Ben

0
Comment actions Permalink

Ok, it happened this afternoon but I can't rememeber what time - probably within the last couple of hours of the log file's last entry.

File attached.

Ben



Attachment(s):
20120222.txt.zip
0
Comment actions Permalink

Hello Ben
     Thank you very much for the log! Have you checked if closing and reopening the file helps to fix this problem? Also, does it stop working in a certain file only or in any file?

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

Hi.

I tried closing the file and re-opening but it did not work.  I then closed all open fiels and re-opened the file and it did not work.

I had to restart VS to get it to work.

Ben

0
Comment actions Permalink

same for me.  A few times a day.  Only restarting VS fixes it

0
Comment actions Permalink

The same is happening for me.
I also notice that IntellSense immediately and consistently turns off when I load SOME solutions - this behaviour may relate to solutions that do NOT have a "<solution_name>.6.1.ReSharper" file??
I also notice that this file does not get created by ReSharper either (I have tried starting VS2010 with "Run as administrator"), should it be automatically created?

This issue occurs on 2 PC's that have access to these projects; version's below:

PC #1 (log attached)
Windows 7 SP1
VS2010 10.0.40219.1 SP1 Rel
ReSharper 6.1.1000.82
Visual SVN 2.5.3
RedGate Relector 7.5.2.1
.NET Framework 4.0.30319 SP1 Rel

PC #2
Windows 7 SP1
VS2010 10.0.40219.1 SP1 Rel
ReSharper 6.1.37.86
Visual SVN 2.5.4
RedGate Relector 7.5.2.1
.NET Framework 4.0.30319 SP1 Rel

I have attached the log file and it does indeed show an exception being raised by ReSharper:
12:01:49.291: Thread:1: EXCEPTION: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))
The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))



Attachment(s):
log.zip
0
Comment actions Permalink

Any assistance JetBrains?

0
Comment actions Permalink

Hello
     Sorry for delayed response! Yes, the file should be created automatically, so this may indicate a problem. Does other ReSharper's functionality (such as navigation, code highlighting etc) work with those solutions? As to the log file, we did not find anything suspicious in it. Thank you!

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

Hi Andrey,

Thanks for your response.
Everthing else does appear to work correctly at all times.

To be more accurate with my earlier description of the problem: when I start the solution and check the Statement Completion settings ('Tools' > 'Options...' and then 'Text Editor' > 'C#') they immediately show as turned off, however, the Statement Completion/Intellisense DOES still work for a period of time; eventually and randomly it stops working, as described by others.

The more I experience this, the more I feel it is related to the missing "<solution_name>.6.1.ReSharper" file as I have yet to experience the random stopping in solutions that do have these files.
I've also noticed that where these files do exist there are also prior versions of these files (5.1 or 6.0).
In addition, I am unable to get ReSharper 6.1 to create these files in any new or existing solutions.
I have tried uninstalling and reinstalling.

Thanks

0
Comment actions Permalink

Okay, so I've taken the missing "<solution_name>.6.1.ReSharper" file further...

When I uninstall and then install ReSharper version 6.0, the file "<solution_name>.6.0.ReSharper" is created... and the Intellisense/Statement Completion option shows as enabled (I've not run it for long enough to see if it stays enabled).
If I then uninstall 6.0 and install version 6.1 the file "<solution_name>.6.1.ReSharper" IS also created, but only where a prior version exists. And again, the Intellisense/Statement Completion option shows as enabled when this file exists.
The "<solution_name>.6.1.ReSharper" file is still not created for new solutions or existing solutions where no prior version existed.


So in conclusion, out of the ReSharper versions I have tried. The version that works (for me) is 6.0.2202.688, and the versions that don't work are 6.1.37.86 and 6.1.1000.82.
I hope this helps you guys get a little closer.

0
Comment actions Permalink

Nah, the "<solution_name>.6.1.ReSharper" file doesn't relate to the Intellisense options randomly turning off. I've just lost my Intellisense on a solution that does have this file - albeit on a solution that only created the 6.1 file after reverting to 6.0 to create a prior version first (as discussed above).

0
Comment actions Permalink

I just sent in a support question to JetBrains with the same issue. Has JetBrains responded with any possible solution? Obviously, I'm not seeing one in this thread but didn't know if they had responded directly to anyone.

Thanks
Stu

0
Comment actions Permalink

Hello
     Do I understand correctly that IntelliSense restores its functionality as soon as you suspend/resume ReSharper under Tools | Options | ReSharper | General? Could you please attach a screenshot of ReSharper | Options | Environment | IntelliSense | Autopopup taken immediately after IntelliSense stopped working? Thank you!

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

Hi Andrey

Apologies, but I've been using VS very little in the past few days therefore I've not experienced the random stopping.


However, in regards to the statement completion options showing as switched off (unchecked), but Intellisense still works correctly (as described above)...
If I suspend ReSharper and then close and reopen the Options screen, the two options are now shown as on (checked).
If I then resume ReSharper and then close and reopen the Options screen the two options again show as off, but Intellisense still works.
This cycle continues each time I suspend/resume.

The statement completion options are found in Tools | Options | Text Editor | C# and are named "Auto list members" and "Parameter information".
I used Tools | Options | ReSharper | General to suspend and resume ReSharper.
The statement completion options show as switched off right from first opening a solution and occurs virtually every time.
The statement completion options for all other languages appear to be unnaffected.
The setting in ReSharper | Options | Environment | IntelliSense | Autopopup do not change from "Display and preselect" (for C#).
The projects are all C#/XML/XAML.


I will post again if Intellisense stops working randomly.

0
Comment actions Permalink

Hi Stu,

I've not received a solution. Have you?

If the random stopping occurs for you again could you please try the suspend / resume and post a screenshot test as requested by Andrey above?
I would be so good to nail this and get ReSharper back.

0
Comment actions Permalink

In addition, when the two statement completion options are showing as switched off; if I try turning them on, click OK and then reopen the Options screen they still show as off.

0
Comment actions Permalink

[delete double post]

0
Comment actions Permalink

I have a similar problem but I believe I've narrowed it down to the usage of non-standard variables in the csproj file (VS2010, Resharper 6.1.37.86, C#).

Log attached.

VS was started with Resharper suspended. As soon as I resumed resharper, intellisense stopped working for any types from a dll included using non-standard variables.

The problem (I believe)

Referencing a file in the csproj like this:


    <Reference Include="SG.Types.Bond">
      <HintPath>$(EnlistmentRoot)\private\src\ObjectStore\Bond\$(BondTypesDllConfig)\$(BondTypesDllPlatform)\SocialGraph.Types.Bond.dll</HintPath>
    </Reference>


I believe Resharper may choke on having the properties/variables like '$(BondTypesDllConfig) in the hint path.

The example file (DemoTest.cs) in the CoprocTest project uses some types from this dll.

If I get rid of the custom variables in the reference element and replace them with hardcoded values (a temporary workaround), it is fine.

HTH

S



Attachment(s):
vs_resharper_log.zip
0
Comment actions Permalink

My theory isn't correct. Whilst having non-standard variables in the reference makes it fail always, I  have a project that includes this dll directly which also causes Resharper to choke.

I have tried many different combinations but still haven't isolated the cause. Hopefully the log helps.  

0
Comment actions Permalink

For the projects where I have this problem suspending Resharper results in intelliSense working again, resuming Resharper stops it working.

It's not a random stop though - it just doesn't work for the types coming from a specific referenced dll, in some projects but not all.

0
Comment actions Permalink

I have created a screen capture video showing the problem.

You can see

- Intellisense working for a lot of things around where I make the edits during the video
- But not working for the example types TestId and TestString which come from the dll I'm having issues with
- The types resolve (show in blue) until you complete them with ',' or '>' in the example (show in red with 'Cannot resolve symbol' message)
- The types can be resolved by hitting Ctrl+J (46s in)
- Suspending Resharper makes the problem go away
- Resuming Resharper makes the problem reappear

https://skydrive.live.com/redir?resid=69D18A0AE63B46D2!8525&authkey=!AJKXIyAz9u7ccx8

HTH

I don't see any signs of problems in the resharper log (created with /ReSharper.LogLevel Verbose).

S

0
Comment actions Permalink

I am seeing this problem as well.

I see this only when working with Razor projects.

If I suspend/resume ReSharper, the functionality returns.

I have this problem on multiple machines.

0
Comment actions Permalink

Can we get a solution to this? I am getting tired of having to suspend/resume
my resharper at least twice a day.

0
Comment actions Permalink

I'd settle for a work around. Or at least a hint that someone is looking at this...

0
Comment actions Permalink

Hello
     We're looking into this problem, however we have not been able to find out what's causing this behavior yet. As a workaround, you can switch to built-in Visual Studio IntelliSense under ReSharper | Options | IntelliSense | General. Thank you!

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

That doesn't help - which hopefully provides some clues as to what's going wrong.

I have to suspend Resharper for intellisense to work for the types coming from one specific referenced dll - even with it set to use Visual Studio Intellisense.

0

Please sign in to leave a comment.