MSTest without shadow copy still has wrong directory


First off, I'm using an odd release of Re-Sharper. I'm using 7.1.3000.1964 that I got from

I did this because I'm running VS2012 with update 2, and the tests weren't running at all.

Anyways, I'm using MSTest methods, but I need the directory to be in the regular place.. as it is, it's going to here:

        Assembly.GetExecutingAssembly().Location    "C:\\Users\\xxxx\\AppData\\Local\\Temp\\TestResults\\xxxxxxx 2013-04-11 13_38_16\\Out\\xxxxxxxx.Test.dll"    string

I unchecked "Shadow Copy" in the Unit Test settings in the options menu. This is a very big problem for me, because my project is large and contains plug-ins that are copied into bin with custom build tasks on the .csproj, so I can't even use ReSharper unless the path is the same as what MSTest usually uses.

Note that using VS MSTest on its own works fine with no issues.

Please advise. Thanks.

Please sign in to leave a comment.