Disabling CamelHump Ctrl+Arrow navigation

I'd like to revert to the default VS2010 behavior of Ctrl+Arrow (left/right) jumping full words, instead of jumping by camel case (as is the case in ReSharper).  I cannot manage to get this change to take affect.  

I went to Tools -> Options -> Keyboard.  In the shortcut key area, I hit Ctrl+Left Arrow.  I get a "Shortcut Currently Used By: Edit.MoveControlLeft".  For the sake of thoroughness, I went ahead and Re-assigned Ctrl+Left Arrow to Edit.MoveControlLeft, even though it was already set.

Furthermore, if I lookup commands containing ReSharper_HumpNext (and ReSharper_HumpPrev), and neither of these commands have an existing shortcut command assigned to them.

After the above steps did not help (including a restart of VS2010), I did Tools -> Import/Export Settings -> Reset All, and reset everything.  Custom shortcuts I had enabled previously were gone after this (so it did do something), but Ctrl+Left Arrow and Ctrl+Right Arrow are still navigating by camel humps.  Any idea how I can get the default VS behavior instead?

Regards,
Matt

2 comments
Comment actions Permalink

I think what you want to do is is ReSharper -> Options -> Environment  -> Editor and uncheck Use CamelHumps.

0
Comment actions Permalink

Thank you sir, you just made my day!

0

Please sign in to leave a comment.