unit test session window is hidden

I feel like I am missing something obvious here but I can't figure it out.

I can only view the unit test sessions while debugging, which means I never get to see the test results.  I have tried the resharper->windows->Unit Test Sessions menu option and the shortcut keys.  I have right clicked in the unit test explorer window (which works fine) and selected "new unit test session for selected items".  None of these works.

I have tried rebooting and deleting all the resharper files from the project.  I have uninstalled version 4.5 and then installed version 5.1.  Still no luck.

Whenever I try to open the window the VS title bar gets greyed out, like it is being put in the background but the unit test session window is not visible.

I am working in VS 2008.

Any ideas?

8 comments
Comment actions Permalink

Hello Rob,

Looks like your Unit Test Session window got off screen. VS persists locations
of tool windows, and sometimes fails to restore them correctly, especially
if screen resolution changes (e.g. you changed your screen resolution, or
logged in with Remoted Desktop with different resolution). Locations are
stored in .suo file near your .sln file. Try closing VS, delete .suo file
(make a backup) and restart VS. 

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


RC> I feel like I am missing something obvious here but I can't figure
RC> it out.
RC>
RC> I can only view the unit test sessions while debugging, which means
RC> I never get to see the test results.  I have tried the
RC> resharper->windows->Unit Test Sessions menu option and the shortcut
RC> keys.  I have right clicked in the unit test explorer window (which
RC> works fine) and selected "new unit test session for selected items".
RC> None of these works.
RC>
RC> I have tried rebooting and deleting all the resharper files from the
RC> project.  I have uninstalled version 4.5 and then installed version
RC> 5.1.  Still no luck.
RC>
RC> Whenever I try to open the window the VS title bar gets greyed out,
RC> like it is being put in the background but the unit test session
RC> window is not visible.
RC>
RC> I am working in VS 2008.
RC>
RC> Any ideas?
RC>
RC> ---
RC> Original message URL:
RC> http://devnet.jetbrains.net/message/5268076#5268076


0
Comment actions Permalink

Thanks Ilya.

That did not work at first.  I deleted my resharper 4.5 file (something I had tried previously, before deleting the suo file) and now its working.  Not sure if it is because of deleting both files or what, but it works now.

Thanks!

Rob

0
Comment actions Permalink

Hello Rob,

Please try Window > Reset Window Layout from the main menu. Thank you!

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Thanks Ilya.

That did not work.  Any other ideas?

---
Original message URL:
http://devnet.jetbrains.net/message/5268085#5268085



0
Comment actions Permalink

It is working now. See above. Thanks Andrey.

Rob

0
Comment actions Permalink
I have exactly the same problem as described by RC. But it's happening on Resharper 7.1.3 and VS2010. I tried the suggestions from this thread: that are: deleted .suo, deleted [user]\AppData\Local\JetBrains\ReSharper\v7.1, Reset Windows Layout. No help. I also have the same Resharper version installed for VS2012. It works fine. I am running Windows 7. Is there another way to solve the problem?
0
Comment actions Permalink

Hello John,

  Could you please try to aplly Tools | Import and Export Settings | Reset All Settings | General Development Settings | Finish?

  Please backup your settings before (Tools | Import and Export Settings | Export selected environment settings).

Thanks!

0
Comment actions Permalink
Update: Without any additional work, after about half day, I just saw the window come back. The only extra thing I did was: getting into debugging mode, show the unit test session window, and moved it around. I am not sure if that resets the last location.
0
Comment actions Permalink

I had this problem with VS 2015 and Resharper 10, then I used windows key + arrow keys to bring it back. In my case, it probably was because of the multiple monitors' misconfiguration or smt.

0

Please sign in to leave a comment.