6 comments
Comment actions Permalink

I can't help with the exception when reporting the exception, but I can answer the questions for the extension manager.

8.1 is not binary compatible with 8.0, so plugins need to be recompiled, and potentially updated. We maintain API compatibility between maintenance releases (e.g. 8.0.0 -> 8.0.2) but with a minor or major release, we need to evolve the API and that causes breaking changes.

The majority of the installed extensions you have don't support 8.1 - the extension manager is looking in a different location within the package for the files to load. We don't currently display any warnings to that effect in the UI, which is something we may address in future builds. The warnings you're currently seeing are because those two plugins are packaged incorrectly, and the plugins are in the wrong folder in the package. Plugins need to be stored in a folder that matches the current version of ReSharper, and these have been placed in a folder shared by all versions. ReSharper is trying to load the plugins, realises they're for an older version and stops, displaying the warning. The shared location is intended for setting and xml annotations, which are version independent.

I'll notify the plugin authors.

Thanks
Matt

0
Comment actions Permalink

Ok, thank you

:)
0
Comment actions Permalink

i had similar errors some times (error 403, forbidden). I just retried to submit a couple of times and the fourth or fifth attemp was successful. Maybe the server was just overloaded.

Regards
Klaus

0
Comment actions Permalink

admins pls delete this post..

:)
0
Comment actions Permalink

Ok, I found what the error was. So in Visual Studio it says that my password is wrong. Then I went to youtrack.jetbrains.com and logout then logged in, then logged in VS and now it says password is fine and I can submit exceptions. :)

0

Please sign in to leave a comment.