Resharper seems to stop Visual Studio from being able to resolve domain names

I've been having a recurring issue in Visual Studio where I can open up a project, work with it normally, check out files.  But after a seemingly random amount of time I'll go to do an operation that requires something over the network and VS will not be able to resolve the domain name.  Usually I'll be checking out a file and I'll get a "The remote name could not be resolved for X" where X is the name of our TFS server.  If I restart VS then things go back to normal.  For a while.  I've been getting some help from the MSDN forums to try and track this down, but it seems that the issue is related to Resharper.  For those that don't want to read through the whole thing the timeline looks a lot like this:

  • I have VS2012 with Resharper 8, problem occurs
  • Upgrade to VS2013 with Resharper 8, still get the problem
  • Uninstall Resharper, I don't get the problem with VS2013 for a whole day, but coding is a pain because I'm so used to having Resharper
  • Decide I miss Resharper too much and install it
  • This problem occurs 20 seconds after I've opened my solution and then again 5 minutes later


There are quite a few developers where I work and most of them use Resharper and I am the only one that gets this issue.

Does anyone have any ideas about what could be causing this?

2 comments
Comment actions Permalink

While I thought I was alone with this problem, it seems I have one other colleage with this problem and he just has to suspend, then un-suspend Resharper and things will start working again most of the time.  We found this StackOverflow questions quite useful for figuring out better way of doing this:

http://stackoverflow.com/questions/2189792/how-can-i-disable-resharper-in-vs-and-enable-it-again

0
Comment actions Permalink

I never did get to the bottom of this problem, but it eventually got so bad that I had my machine rebuilt (and went from Win7 to 8.1 at the same time).  Since doing this it's been fine, but it was a pretty extreme measure to take.

0

Please sign in to leave a comment.