Unit Test Runner failed to load assembly Microsoft.VisualStudio.TestTools.UnitTesting

Hello all,

there is a problem with Unit Test Runner:

UnitTestRunnerFailed.png
A few days ago tests runs fine.

ReSharper version: JetBrains ReSharper 5.1 C# Edition Build 5.1.1766.4 on 2011-01-12T16:31:10
Visual Studio 2010, project type WPF in .NET 4.

References in project are good, I can display assembly details (Microsoft.VisualStudio.TestTools.UnitTesting version 10.0.0.0) in Object browser well.

I tried repair Resharper from installer without any effect.

What can I try next?

Thank anybody for tips.

5 comments

Yes, I have added them recently.

0

CodedUI tests are not supported in ReSharper 5.

Workaround is to copy 4 assemblies namely:
Microsoft.VisualStudio.QualityTools.CodedUITestFramework.dll
Microsoft.VisualStudio.TestTools.UITest.Common.dll
Microsoft.VisualStudio.TestTools.UITest.Extension.dll
Microsoft.VisualStudio.TestTools.UITesting.dll
from C:\Program Files (x86)\Microsoft Visual Studio  10.0\Common7\IDE\PublicAssemblies to project's bin\Debug folder.

This will allow to run unit tests from this assemblies.

However it will not help to run Coded UI tests. At the moment they're  not recognized and not supported. There is an issue for this problem:  http://youtrack.jetbrains.net/issue/RSRP-192236

0

Great job!

Thank you for reply.

It looks like a bug. When I use this directive: using Microsoft.VisualStudio.TestTools.UnitTesting; and reference needed assebmly - it prevent run all tests in the class :(. Visual Studio can work fine with this assembly, but RS no.

0

That is what im looking for. But i cant find these files in myfolder :(
What can i do ?

0

Please sign in to leave a comment.