Code Cleanup: XML Doc Comments - param tags are always wrapped

Hi,

I have updated ReSharper today to the most recent 8.2 version, and I have installed the newest version of StyleCop.
Now I'd like to configure the Code Cleanup for C# files to not touch the following comment example (esp. regarding the param and return tags, the content shall not be placed on a separate line):

        /// <summary>
        /// Do something.
        /// </summary>
        /// <param name="commandLine">The command line.</param>
        /// <param name="starterApp">The starter application instance.</param>
        /// <returns>A value indicating whether the Param.app file has been processed successfully.</returns>

But after performing a silent code cleanup, the comment always looks like that:

        /// <summary>
        /// Do something.
        /// </summary>
        /// <param name="commandLine">
        /// The command line.
        /// </param>
        /// <param name="starterApp">
        /// The starter application instance.
        /// </param>
        /// <returns>
        /// A value indicating whether the Param.app file has been processed successfully.
        /// </returns>


I've tried a lot of settings, all of them in the "this computer" level, and I have deleted all ReSharper settings files for the solution. I even switched off Code Editing / Code Cleanup / C# / Reformat embedded XML doc comments, but the param and returns contents are always placed on a separate line. Any hint how I can solve this?
2 comments
Comment actions Permalink

Hello Mathias,

  Could you please remove StyleCop extension from ReSharper and then try reproducing the issue once again? I am 99 percents sure it is a Stylecop issue.

Thanks!

0
Comment actions Permalink

Hi Alexander,

today I tried again and switched off everything in the documentation section (see Screenshot), and now I get the code cleaned up the way I like it. I have no idea why I haven't tried that before...

Thanks,
Mathias



Attachment(s):
ReSharper StyleCop.png
0

Please sign in to leave a comment.