Installing dottrace has broken resharper

Hi,

My company standardises the environment developers use in order to make sure everyone is working with the same products. Currently this includes:

Resharper 8.2.0.2160
Dotcover 2.7.1.238

We only have licenses for these versions, not the latest versions.

I have recently been tasked with improving code performance, so I tried to install the latest version of Dottrace (dottrace.web.01.exe). However, after I installed Dottrace the old versions of Resharper and Dotcover stopped working properly (details below). I uninstalled Dottrace, but they still didn't work. I reinstalled visual studio, reinstalled resharper and dotcover, but they still don't work.

The current symptoms I am seeing are:

- Visual Studio has acquired an "Analyze" menu. This includes "Performance and Diagnostics" and "Performance" menu entries. This appears to be associated with Dottrace, and is shown even though Dottrace has been uninstalled

- A Resharper menu is present, but it has very few entries. If I select "Help-License information" it says "No product installed". This occurs even though Resharper is shown as installed in control panel.

- A Dotcover menu is present, and dotcover appears to be present. However it seems to think that unit tests will be run through Resharper, so won't show it's test runner (which given that Resharper isn't properly installed, this means I can't measure code coverage).

Any ideas as to how I can repair my environment?

9 comments
Comment actions Permalink

Hello,

The newer versions of all the products are now a part of the ReSharper Ultimate
suite not only from the marketing point of view, but they're also all a part
of ReSharper in their integration into Visual Studio. So if you install any
of the Ultimate members of the latest verison they're in fact not compatible
with any previous versions of ReSharper. You can't have both integrated into
the same Visual Studio.

To restore older R#, uninstall the newer products' Visual Studio integration
part, and then repair the older products to refresh their integration.

You can still have the out-of-VS experience of the newer DotTrace side-by-side
with in-VS versions of the older products. For that, VS intergarion should
be unchecked when installing the newer products.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

The problem isn't that I haven't done these things. The problem is that I have done them, and they aren't working.

I've already removed the newer product (dottrace) through control panel. Except it still seems to be partially installed. I still see an "Analyze" menu, and menu options such as "New Performance Session" still seem to function. So how is dottrace still present in Visual Studio when it's not showing up in my list of installed programs?

I've already tried completely uninstalling all related products (resharper, dotcover, dottrace and even visual studio), and then re-installing Visual Studio, Resharper and DotCover. This has made zero difference. I am still left with dottrace menus and no resharper.

Following your suggestion, I've just tried repairing both Resharper and Dottrace. That's made zero difference - I'm still seeing exactly the same symptoms.

0
Comment actions Permalink

Anyone? Short of completely reinstalling windows, is there any way for me to repair my PC, and get my licensed versions of resharper and dotcover working?

0
Comment actions Permalink

Have you run repair on Visual Studio?

Have you uninstalled/reinstalled Visual Studio?

0
Comment actions Permalink

I have uninstalled and then re-installed Visual Studio. That did not fix the issue.

0
Comment actions Permalink

Any progress? I'm getting quite annoyed at this.

Your product (Dottrace) has messed up my Visual Studio environment, to the extent that other products we have brought from you (in particular ReSharper), no longer function correctly.

It is quite plain that the uninstaller for Dottrace does not properly remove the application from my PC. I still see Dottrace menus, and they still seem to function.

You have not replied to my mails to your support team.

I currently don't have a fully working development environment, and this has been going on for more than a week. How can it be fixed?

0
Comment actions Permalink

Hello Chris,

  First of all, Analyze menu item is not JetBrains one, it is standard Visual Studio one https://msdn.microsoft.com/en-us/library/ms182372.aspx or http://blogs.msdn.com/b/visualstudioalm/archive/2013/07/12/performance-and-diagnostics-hub-in-visual-studio-2013.aspx

  As for ReSharper, what version did you try to install - 8.x or 9.x?

Thanks!

0
Comment actions Permalink

A small update. The problem has finally been solved by Maria from JetBrains support.

In case anyone else suffers from the same issue, all that is needed is to delete the folder: C:\Users\[user_name]\AppData\Local\Microsoft\VisualStudio\[version_number]\Extensions\JetBrains

0
Comment actions Permalink

Hello,

This also can be achieved by running the Checked version of the installer
(preferrably, under the same user as the one having problems, but tries to
do all).

Checked builds can be found on products' download pages via the "previous
versions" link


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.