Using Move Hyper-V/RDC Session

Hello Community,

I am having a heck of a time trying to get ReSharper to move symbols within my code Up, Down, Left and Right.  Right seems to work as expected in Hyper-V.  However, all other directions cause the instance Hyper-V session to lose keyboard and mouse control, and I have to click somewhere in the window to re-establish it.

With a Remote Desktop Connection, the method and symbols highlight, and I get a "Use Up/Down to Move <Method>" and "Use Left/Right to Move <Parameter>."  However, when I press these buttons, nothing happens.

Is this a known issue?  Is there a way to initiate the "move" scenario that does not involve CTRL-ALT-SHIFT?  It would be great to get this functionality.

Thank you,
Michael

6 comments
Comment actions Permalink

In Visual Studio,

  • Select Tools Menu
  • Select Options
  • Under Environment select Keyboard

For each of  the commands:

  • Reshaper.Resharper_MoveDown
  • Resharper.Resharper_MoveUp
  • Resharper.Resharper_MoveLeft
  • Resharper.Resharper_MoveRight


Create a new shortcut in Text Editor, choose your keys  and then click assign assign
0
Comment actions Permalink

Hi Bob,

Thank you for your reply.  I have tried working with those shortcuts and unfortunately they do not work as expected, or at all.  They are dependent on the CTRL-SHIFT-ALT state before working.  That is the "shortcut" I really need to be able to adjust in order to fix this issue.

Thanks again,
Michael

0
Comment actions Permalink

I think you misunderstood.

Those instructions will allow you to assign a completly new shortcut.  Just assign a different key sequence and you will be fine

0
Comment actions Permalink

Hah!  Yes, I misunderstood and I didn't do a good job explaining what I was seeing. :)  By default, CTRL-SHIFT-ALT puts ReSharper into "move" mode.  That is, holding those buttons down on a symbol highlights the row/symbol and displays the message "use up/down to move <method>, use left/right to move <parameter>".  This is what I was looking for when assigning new keys.  However, assigning new keys to these commands DO work after all.  I did try this earlier, but had no success. It's working now though.  I appreciate the assistance, Bob!

0
Comment actions Permalink

FWIW/FYI here is a bug I found with explicitly setting the keys: https://youtrack.jetbrains.com/issue/RSRP-435698

0
Comment actions Permalink

Well I have to say that even though you can remap the keys, it just isn't the same as the original.  You lose the designer experience and that sort of stuff adds up when using RDC.  It would be nice to regain this, so I have created an issue for this.  Please upvote here:

https://youtrack.jetbrains.com/issue/RSRP-464502

0

Please sign in to leave a comment.