Extension Manager displays install success message, but extension is not installed

I am unable to install any ReSharper extensions even though the message displays that the install was successful. The install is instaneous and none of the links to log files, support, etc. work either. Here is my current version:

JetBrains ReSharper Ultimate 2015.1 Build 102.0.20150408.145317
TeamCity Add-in 9.1.20150408.154542
dotCover 3.1.20150408.155159
ReSharper 9.1.20150408.155143


Has anyone else had this issue?

Thanks,
Derek
11 comments
Comment actions Permalink

Hmm. There are two things you can try. Firstly, run Visual Studio with "devenv /ReSharper.Internal". This enables ReSharper's exception reporter, so keep an eye out in the bottom right of the status bar for exception messages when you try and install an extension. Secondly, you can take a look at %LOCALAPPDATA%\JetBrains\Shared\v02 for installer logs - you might be able to spot something in there (or paste it here and we can take a look).

0
Comment actions Permalink

I checked in the %LOCALAPPDATA%\JetBrains\Shared\v02 folder and found the InstallerLogs00x files. I opened the most recent one, manually added a text separator, and tried both methods of installing an extension. I did not see any exceptions nor any additional logged items.

Where else can I look or what else can I try?

Thanks,
Derek

0
Comment actions Permalink

The installation would have created a new log file, rather than appending to the existing one. Is there anything useful in the new log file?

0
Comment actions Permalink

There's no new log file. InstallerLog14 is the most recent one and was updated this morning. I've attached it to see if anything in there might help.



Attachment(s):
InstallerLog014.zip
0
Comment actions Permalink

There's nothing useful there, unfortunately. What extension were you trying to install? And can you tell me what you've got in your %LOCALAPPDATA%\JetBrains\plugins folder?

0
Comment actions Permalink

I was trying to install ReSpeller Free but it happens with *any* extension. Here's the contents of that folder:

  • Wave.2.0.0
  • JetBrains.ExternalAnnotations.9.1.0.3
  • CitizenMatt.PreviewTab.1.1.4
  • ReSharper.Postfix.R90.2.0.9
  • Ulex.ZenSharp.1.1.1.8
  • repositories.config
  • packages.config

I also posted a screen recording of what happens during the install and how the links don't open. Let me know what else I can provide.


Attachment(s):
ReSharperExtensionIssue.swf
0
Comment actions Permalink

Hi Derek!

First, issue with not seeing error log of Extension Manager is fixed and will be deployed in next minor update.

You can still see it by running VS with logging: devenv.exe /ReSharper.LogFile "C:\resharper.log" /ReSharper.LogLevel Verbose

But I can suggest simple workaround - just clear content of %LOCALAPPDTA%\JetBrains\Plugins and try to install plugins again.

0
Comment actions Permalink

Thanks for the solution, Slava! Once I cleared out the plugins folder, all the extensions got installed. I did take a look at the log file using your command line and there were many exceptions around DNS queries:

13:38:27.239 |V| LicenseViewModelBuilder       | DNS query fails

I'm not sure if that is common, but I thought I would mention it.

Many thanks to Matt for helping out, too!

--Derek

0
Comment actions Permalink

Hello,

Hmm. There are two things you can try. Firstly, run Visual Studio with
"devenv /ReSharper.Internal". This enables ReSharper's exception
reporter,


Actually, this only shows select errors and does not fully enable the exception
reporting.
It's recommended to install the Checked build of the same version if you'd
like to investigate into errors for real.
Especially when debugging problems with plugins, not to mention authoring
plugins.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Hi Serge,

Clearing the plugins folder solved my extension install problem and I don't do any extension authoring. I've attached the ReSharper log so you can see what exceptions are happening under the covers - which do not affect the running of ReSharper or Visual Studio - as far as I can tell. If you decide you would like me to run a checked build to help solve these, please reach out to me.

Thanks again for all the help,
Derek



Attachment(s):
resharper.log.zip
0
Comment actions Permalink

Hello,

Thanks.
Luckily, there's no need for that as everything works now.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.